Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am connecting from a Windows 7 workstation to a Server 2003 server, and it seems the "StickyKeys" dialogue box (on the server side) appears whenever Shift is pressed- even if it is just pressed once (and even then, very quickly). I'm not holding it down for a long time or anything. This issue is frustrating as it makes actually typing in the password to remotely connect challenging.

What I know so far:

  • all our Windows 7 PCs in the office have this problem
  • none of the Windows XP PCs have this issue. StickyKeys only appears when pressing Shift 5 times (as it should).

Interestingly enough: avoiding using full screen mode on the remote desktop session actually prevents this problem happening. If Remote Desktop session is any resolution other than "full screen" mode, it works fine.

Does anyone have any idea what is going on here? How I can fix it so we can continue to use full screen mode whenever we connect to the server from Windows 7 systems, without it launching StickyKeys the instant (either) Shift key is pressed? If it worked fine in XP, I'm sure there's a way to get it to work in Windows 7.

Thanks, d-man

share|improve this question
    
This is probably all too obvious but can you not disable sticky keys on the server side locally? –  ϺОŞΣŞ Feb 25 '13 at 2:49
    
I've just tried disabling StickyKeys on the server through both the GUI, and also in the registry, and I can't make it go away. Also, when the StickyKeys dialogue box pops up, choosing "Settings" doesn't do anything. –  Austin ''Danger'' Powers Feb 25 '13 at 14:38
    
You said "This issue is frustrating as it makes actually typing in the password to remotely connect challenging." Which would imply this is happening before the client is connected, so could the issue be client-side? –  ϺОŞΣŞ Feb 25 '13 at 17:10
    
It's definitely server-side. The StickyKeys dialogue box is within the Remote Desktop window and looks "XP-like" rather than "Windows 7-like". Also, I can't move it outside of the Remote Desktop window and it doesn't appear normally on the Windows 7 machine when not using Remote Desktop. If I log on to the server locally and hit Shift 5 times, the exact same popup appears. –  Austin ''Danger'' Powers Feb 25 '13 at 17:24

1 Answer 1

up vote 4 down vote accepted

Try this:

  1. Click Start, click Run, type mstsc.exe, and then click OK.
  2. In the Remote Desktop Connection dialog box, click Options, and then click the Local resources tab.
  3. In the Apply Windows key combinations list, click On the local computer.
  4. On the General tab, click Save As, type a name in the File name box, and then click Save.

From: http://erlingdandersen.blogspot.com/2009/04/windows-remote-desktop-and-sticky-keys.html and http://support.microsoft.com/kb/926934

share|improve this answer
    
This will do. Thanks –  Austin ''Danger'' Powers Feb 25 '13 at 17:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.