Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

when i was trying to install emacs on Linux Ubuntu .I used to search emacs in add/Remove search toolbar it shows Emacs 22 ..i have double clicked that emacs it shows the following error.

Emacs 22 (GTK)

Canonical Ltd. provides technical support and security updates for Emacs 22 (GTK) Emacs 22 (GTK) cannot be installed on your computer type (i386). Either the application requires special hardware features or the vendor decided to not support your computer type.

share|improve this question

migrated from stackoverflow.com Oct 15 '09 at 9:58

This question came from our site for professional and enthusiast programmers.

1  
You should be asking this on superuser.com –  gnibbler Oct 15 '09 at 5:46

5 Answers 5

And, I just noticed how old this is. I've got to stop paging through.... :-)


Which ever repository your Ubuntu install is pulling Emacs from is provding the x86_64 version (well, that's what is sounds like).

Open the synaptic Synaptic package manager and under the "Settings" menu select "Repositories".

Make sure the first two boxes are checked (main, universe)

Then switch to the "Other Software" tab. Temporarily disable everything here, but make sure to not which ones are checked.

Click on Reload.

Now, search for Emacs here.

Select and install emacs.

Did that work? I'm really guessing here. The only time I've seen the same or nearly same error was when trying to install a 64bit package on a 32bit machine. Normally I run only 64 bit workstations and server, so I don't see this often.

share|improve this answer

The latest version is Emacs 23, version 22 does work on i386 of course, but it may be an issue with the packaging system which hasn't been fixed because everyone installs 23 instead. Is their a reason you can't install emacs 23?

share|improve this answer

fire up the terminal and type:

sudo apt-get install -y -f emacs

-y for yes to all downloads

-f use force (bypass all warnings)

share|improve this answer
    
I'd try it without the -f first. If it bombs and the reason isn't obvious, then use -f. –  quack quixote Oct 15 '09 at 12:17

Bizarre. The problem is not your computer type, since Ubuntu Emacs 22 is installed on thousands of i386 machines (including mine). Try installing the package emacs-snapshot. It's the latest dev version of Emacs 23. This is just a shot in the dark, though. My guess is that you may want to upgrade (or even reinstall) Ubuntu when the next version comes out (Oct 29--- a week away), since I suspect that installing Emacs may not be your only problem!

share|improve this answer

Under Ubuntu 9.10 (which I upgraded to TODAY, from 9.04 - with NO GOTCHAS) when I do...

sudo aptitude install emacs

...ubuntu installs emacs22 - so don't go to 23 unless you want to venture into the unsupported.

If you're a heavy EMACS user you might try ensuring you have an emacs-free environment when you do these things. I.e. don't do the upgrade in a shell inside an emacs buffer... and in general make sure EMACS isn't running while you're doing the upgrade.

Also as you see above, unless you have good reason, use aptitude not apt-get

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.