Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the following problem using matlab on Windows 7.

When I double-click a .mat file matlab starts and loads the double-clicked file. Double-Clicking further .mat files opens them also in matlab. So far so good...

On the ohter hand, when I start matlab manually by clicking its Icon on the desktop, I get an "User Account Control" alert asking me if I "want to allow the following program from an unkown publisher to make changes to this computer".

The problem is that a double-click on a .mat file opens another instance of matlab. The running matlab is for some reason not recognized. Does anyone know how to fix this behaviour?

share|improve this question
    
The simple solution is to open the file by hand from within the application. My guess is your using a version not designed to support Windows 7. Here is a good question on that subject: superuser.com/questions/194806/… – Ramhound Feb 25 '13 at 12:56
    
Of course this simple solution works. But I was asking for a solution to this annoying UAC issue. I forget to mention that I use matlab R2011b as all people in our department do without this kind of problem. – user1618022 Feb 25 '13 at 15:38
    
If other people are not having this problem then its a problem with your system's configuration. Until you verify your configuration is correct, not much else we can suggest, if opening the file within the application isn't an acceptable solution. – Ramhound Feb 25 '13 at 15:59
    
That's what I was asking for: What is the problem with my system configuration? – user1618022 Feb 26 '13 at 6:22
    
Thats a better question for your IT staff. Of course I doubt this problem doesn't exist on your peer's computers also. – Ramhound Feb 26 '13 at 12:21

I was able to solve this problem by right-click on the MATLAB icon, then selecting properties. Then I clicked on the Compatibility tab and selected the "Change settings for all users" button. In the window that opened, I unchecked "Run this program as an administrator."

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .