Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install tomcat on my machine(Linux Fedora 15).

I have followed the below steps

  1. I have entered in to root and typed the following

    [root@user ~]# tomcat
    
    bash: tomcat: command not found...
    
    Install package 'tomcat' to provide command 'tomcat'? [N/y] 
    

    I have entered y and result is installed tomcat on machine as below

     * Running... 
     * Resolving dependencies... 
    
  2. Typed the command tomcat to check whether installed or not as below

    [root@user ~]# tomcat
    Usage: /usr/sbin/tomcat {start|start-security|stop|version}
    

    From the above we can confirm that tomcat has been installed right?

  3. Tried to check which tomcat and where is it located as below

    [root@user ~]# which tomcat
    /usr/sbin/tomcat
    [root@user ~]# whereis tomcat
    tomcat: /usr/sbin/tomcat /etc/tomcat /usr/share/tomcat
    
  4. Tried to start the tomcat server as below

    [root@user ~]# /usr/sbin/tomcat start
    /usr/sbin/tomcat: line 30: /logs/catalina.out: No such file or directory
    

So whats wrong here and why the tomcat server is unable to start ? whether need to check/set any other addition settings for starting tomcat ?

Also I tried like below

[root@user ~]# /etc/init.d/tomcat start
Starting tomcat:                                           [  OK  ]

Here i hope it indicates the tomcat has started and hence opened the browser and typed localhost:8080 but the result is

Oops! This link appears to be broken.
Did you mean: localhost-­8080.­com
--------
-------- 

So why I am unable to start the server and view it on browser? Can any one please let me know the procedure to start the tomcat server

share|improve this question

migrated from stackoverflow.com Feb 25 '13 at 9:08

This question came from our site for professional and enthusiast programmers.

    
Did you try to access by 127.0.0.1:8080 – Jason Feb 25 '13 at 9:07
    
yup i tried and still the same error – shiva krishna Feb 25 '13 at 10:56

The problem with the broken logging configuration is covered in this article

In short:

  1. edit /usr/sbin/tomcat6
  2. remove the comments avoiding the load of /etc/tomcat6/tomcat6.conf

But I think more of the configuration is not in a good state.

Generally check the version of your tomcat6 package. I'm suspecting that it is outdated.

See Tomcat6 Changelog - current version is 6.0.36. So check if you can get a more recent package or better - install it manually from the tomcat download page.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .