Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got an e-book reader a few months ago, and I finally figured out why it doesn't display .txt files correctly. It doesn't like ANSI. It has no problem with the other 3 types of coding notepad provides.

For a reason I chose UTF-8 and decoded all the .txt files I have on it (we are talking thousands of small but important documents). They work correctly and now I pay attention to save in UTF-8, but I know myself, I know that at some point I will forget it, and save in the default ANSI.

So the question after the small novel: Is there any way to change the default coding when saving a newly opened notepad? (Win 7)

I know about the way to change the default when opening a previously created .txt file but it's a pain to always create the new document first.

share|improve this question
    
possible duplicate of Is it possible to change the default encoding in notepad? –  Kevin Panko Aug 5 '14 at 17:38

3 Answers 3

This here is a pretty good explanation for how to change your default encoding to UTF-8. You will need to touch the registry files though.

Personally I wouldn't bother with it. Just download Notepad++. It's free, awesome and defaults to UTF-8.

share|improve this answer
    
Notepad2 or Notepad2-mod are more lightweight. They all support set default character set encoding, and even support open 7-bit ASCII file in UTF-8 mode. –  LiuYan 刘研 Feb 25 '13 at 10:18
    
Yes this is the one that only works if I previously create the .txt file. I know Notepad++ but I like the basic notepad's minimalistness, it doesn't use a lit of memory, and for what I need it works fine. Except for this thing... –  Emma Feb 25 '13 at 10:25
2  
In this case just follow the guide and you are good to go. Notepad++ is not at all resource heavy. It's actually the opposite. –  Magnum Feb 25 '13 at 10:39

Here simplest fix -

Just execute once, and it will set regedit parameters to UTF8 Default for Notepad :

http://www.softpedia.com/get/System/OS-Enhancements/Notepad-Default-UTF-8-Unicode-Creator.shtml

share|improve this answer
    
is softpedia a trusted source? –  Yannis Dran Feb 2 at 22:23
    
Didn't work on Windows 7. –  John Feb 23 at 1:14

Trying to offer a clear on-site answer:

  1. Right click on Desktop, then choose New > Text Document
  2. A text file New Text Document.txt is created. Don't type anything and open it.
  3. Go to File > Save As... and choose UTF-8 under Encoding:, press Save and overwrite the existing file. Close the file.
  4. Rename New Text Document.txt to TXTUTF-8.txt
  5. Copy "TXTUTF-8.txt" to C:\WINDOWS\SHELLNEW
  6. Go to Start > Run... and type regedit and press ok
  7. Navigate to HKEY_CLASSES_ROOT\.txt\ShellNew
  8. Right click in the right window > New > String Value and rename it to FileName
  9. Double click on FileName and put TXTUTF-8.txt into Value data: field and press ok

The flaw of this solution is that whenever you want to open a blank utf-8 txt document you will have to right click > New > Text Document and work from there.

Remember: Modifying the registry is dangerous! Use at your own risk.

Source

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.