Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Situation: Desktop PC with SSD (Corsair) as main disk with Win 7 on it. Sudden blue screen today and since then I cannot boot anymore. After many unsuccessful hours now, I turn to you.

The SSD is recognized by the BIOS (MSI mainboard). However, if I enter the Win7 setup disk and enter the System Recovery Tools, no installed windows is recognized and no disks are found by wmic or diskpart on the command line.

Trying to start windows in Safe Mode hangs on ClassPNP.sys.

EDIT 1: Update: I now received my SATA->USB adapter and plugged it into my laptop. The SSD gets partially detected meaning, that in the explorer it starts coming up as four different partitions (there are three actual partitions on the SSD), but only the first one (small 100MB, not one of my three real ones, so probably this is a technical/administrative disk area) shows a size info and can be accessed, although it appears to be empty. Once the laptop completely scanned, all four entries disappear and windows asks me if I want to format the drives. Disk Management does not list the drive.

EDIT 2: Plugged the SSD again into my desktop and it automatically entered System Recovery Tools without any Win 7 boot DVD put in. That to me sounds like the SSD is at least working partially, since these tools need to be loaded from somewhere. The problem is though, that the System Recovery Tools do not recognize any windows installation.

Any ideas on what to try next in order to save the data and possibly get the system back running at least once?

share|improve this question
1  
Tried the drive on another system? –  Shinrai Feb 25 '13 at 18:16
    
Not yet able to, since no adapter available (SATA->USB). Currently trying to procure one online to be delivered tomorrow to do that check. Any other ideas in the meantime? –  Philip Allgaier Feb 25 '13 at 18:25
    
Not really anything that comes to mind that you're any more likely to be able to try, it sounds like it's just toast to me. –  Shinrai Feb 25 '13 at 18:51
2  
@PhilipAllgaier - Until you verify it works in another system any suggestions will have to wait. –  Ramhound Feb 25 '13 at 19:06
1  
@PhilipAllgaier - The drive being recognized simply means the controller on the drive is reporting its existence properly (and the SATA controller in your system is recognizing it) - that doesn't mean the storage functionality of the drive is working, necessarily. The fact that diskpart doesn't see it is a bad sign IMO. –  Shinrai Feb 25 '13 at 19:27
show 5 more comments

1 Answer

up vote 1 down vote accepted

Just wanted to let you know that I eventually was able to find a solution:

With the help of Hiren's Boot DVD 15.2 and more specifically the bootable Parted Magic 2012-10-10 version on it, I finally found a way too read the crucial data from my SSD apparently was still working to a degree but not properly, since Windows still ignores it as do other Linux derivatives (as I mentioned I tried Ubuntu earlier without any success).

Even with GParted it took multiple runs, because after some time the SSD automatically gets unmounted and I had to reboot into GParted again to continue my copying efforts.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.