Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't get Raspbmc to browse my shared folders on my Windows 7 computer that is in the same network. When trying to add a networklocation, I get 'connection timed out'

Things I have tried:

  • I deleted all the workgroups in the network.
  • I've set my network type to 'home network'
  • I've opened up all the setting under 'change advanced sharing settings' both under 'public' and 'home or work'
  • I shared a folder on my Windows 7 computer via -> share with -> specific people -> everyone
  • I installed the latest nightly build
  • I executed 'sudo apt-get install samba' in the terminal, witch stated the latest version of samba was already installed
  • I am able to ping the pc with the shared folder from the pi.
  • Tried turning off windows firewall
  • I've tried making windows users and filling in those credentials when connecting

I have a second computer also running windows 7, XBMC on this pc is able to see my shared folder. I'm fairly technical but really inexperienced with Linux, is there something that I am missing?

Also don't know if this is related but i cant connect via putty, I get 'connection refused'

share|improve this question
    
Could you try to connect from your Raspberry Pi via the command line to Windows? You could do this in 2 steps, first list the available shares and then connect to it. 1. List shares: smbclient -L "\\<windows-hostname>" -U "<workgroup>\username" you can skip the -U ... if you do not need a user. 2. Connect: smbclient "\\<windows-hostname>\<share-name>" -U "<workgroup>\username" you can also skip the -U ... if you do not need a user. What are the outputs or error messages? – Huygens Mar 7 '13 at 9:13
    
Can't connect to WHAT from WHERE via putty? Please be more specific. – jnovack Apr 5 '13 at 13:55
up vote 0 down vote accepted

The few times I have had this problem with RaspBMC the solution has been to reboot my SMB server and/or Raspberry Pi itself. After that I was able to access the SMB shares without any problem.

share|improve this answer
    
Rebooted the server and was able to connect – kevinsky50 Apr 18 '13 at 12:06

I found increasing the memory available to the LanMan server in Windows solved my problem. The answer is described here: http://froebe.net/blog/2013/08/20/howto-samba-protocol-negotiation-failed-nt_status_insufficient_resources-solved-windows-xp-2k8-win7-win8-win2012/

Change the following registry keys: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache -> DWORD value 1 HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size -> DWORD value 3

Then restart the computer, or run services.msc and restart the "Server" service.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .