Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

I can use Charmap utility in Windows to find, copy, and paste the character in any application, including web browsers. But what is the Alt key combination to type in the infinity character?

http://answers.yahoo.com/question/index?qid=20080726061303AA3ZWrr

This Yahoo Answers page says I should use Alt+236 but this only results in a lower case acute Y, like this: ý

I get the same result in Firefox, Excel and Word.

Inserting infinity symbol in Powerpoint 2010

This Superuser page says that the Unicode value for the infinity character is 221e. Does that mean that the Alt key combination is Alt+221? If I use this combination I get this character: ¦

That's a "broken vertical line".

http://www.forlang.wsu.edu/help/keyboards.asp

On this page they are using 4 digits in their Alt key combinations. Does this mean that my Alt key combinations should begin with a zero? Like Alt+0137 for permille character. I also noticed that they are using Alt+0253 for lower case ý character.

So what's going on? And how do I get the correct Alt key combination for the infinity character?

Update

It looks like there is no Alt key binding for the infinity character on my computer. I forgot that the Charmap utility shows you the Alt key combinations. This is what it says for the permille character and the infinity character. See the screenshots below.

charmap 1

charmap 2

As you can see there is an Alt key combination for the permille character. The combination Alt+0137 is used for permille, just like described on that other web page. But notice that there is no Alt key combination listed for the infinity sign.

Why is that? Is it my version of Windows? Is it my keyboard? My keyboard layout? My keyboard language and locale in Windows?

This ultimately leads me to this question: is there a free software application I can use to modify and create my own Alt key bindings for whatever characters I want?

Update 2

This is the contents of my Input Method key in Windows registry.

registry

So as you can see I don't have such thing as EnableHexNumpad.

Update 3

Alright, so I have gone through the trouble of adding this key with the string value of 1 and rebooted the computer.

registry 2

I think the changes are applied now. How do I know? Because when I press Alt and the plus key on the number pad the menu options on the top of the window in applications like Word no longer light up. But I still can't get the infinity sign when I type 221e, or any other hex code for that matter. So changes are applied but have no effect and don't do what I want. Probably explaining why this registry key is no longer there in new Windows systems. My guess is it's deprecated.

Update 4

The last update. I did what Moonbase said and I have merged the registry information he provided with my Windows registry and this is what it looks like now.

registry 3

So I now have the EnableHexNumpad value in the Input Method key. I didn't do it manually like last time. I deleted my old one. Then I copied the reg informaiton Moonbase provided to a new Notepad window and saved it on Desktop with .reg extension. Then I double clicked it to merge it to Windows registry.

I have also rebooted the computer, of course. But this method is still to no avail. I tried it in WordPad, in Notepad, and in Word 2010. I use it like this: I press and hold left Alt key, I then press and hold + key on the number pad, and while still holding both of them I rapidly enter the sequence 221E and let go of all of the keys. It produces the character ¦ which I had before when I pressed Alt and 221.

Sometimes Word 2010 produces a square with a question mark in it, pasting it in here looks like this 𶀥. I'm guessing it's some kind of control character that is not recognized. Maybe I mistyped it. I was using Calibri as font at the time.

In WordPad (Vista) pressing Alt and + key and then the sequence 221E only produces Ý. Pressing only Alt and 221 produces ¦ like it normally does in any given text input program.

Update 5 Hopefully the last update now.

I think I was typing it wrong so it seems to me that, at least when I type in a word processor or notepad, I am able to get the infinity character by typing in the Unicode Hex code. Here's a short sum up.

In Notepad (Vista):

Input: Alt+++(2, 2, 1, E) Output: ∞

Input: 2, 2, 1, E, Alt+x Output: 221e

Font was Lucida Console.

In WordPad (Vista):

Input: Alt+++(2, 2, 1, E) Output: Ý

Input: 2, 2, 1, E, Alt+x Output: ∞

Font was Arial.

In Word 2010:

Input: Alt+++(2, 2, 1, E) Output: ¦

Input: 2, 2, 1, E, Alt+x Output: ∞

Font was Calibri.

In Google Chrome 25:

Input: Alt+++(2, 2, 1, E) Output: Shows the menu (because of Alt+E).

Input: 2, 2, 1, E, Alt+x Output: Nothing happens.

The "omnibox" (search and address bar) was used for text input.

In Firefox 19:

Input: Alt+++(2, 2, 1, E) Output: Shows the Edit menu (because of Alt+E).

Input: 2, 2, 1, E, Alt+x Output: Nothing happens.

The address bar was used for text input.

Excel 2010:

Input: Alt+++(2, 2, 1, E) Output: ∞

Input: 2, 2, 1, E, Alt+x Output: 221e

It requires a little bit of practice to get it right with the Hex code input. I think it helps in some extent to release the plus key first and then release the Alt key after entering the code sequence. I was probably typing too fast and that's why it didn't work the first time. Entering the code first and then pressing Alt+x is much easier than that other method but it doesn't work in all applications.

Correction: The plus key doesn't have to be held while typing the Hex code. So just hold down the Alt key, followed by the plus (don't hold) and the Hex code.

As for browsers, the only thing that works in Google Chrome is entering the code in decimal format, so that's Alt+(8, 7, 3,4) and as for Firefox, I'm not sure what works there. Because this same sequence produces ▲ in Firefox.

share|improve this question

marked as duplicate by Paul, Renan, Xavierjazz, 8088, Hennes Feb 26 '13 at 1:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
What version of Windows do you have? –  Austin ''Danger'' Powers Feb 25 '13 at 23:16
    
@Paul Didn't you read the question? I have included the link to that other page in my own question. I have already seen that page, and I don't see how my question is a duplicate of that one. That guy is obviously trying to get a wall sized print of the infinity character by increasing the font size in Excel. And it didn't work out very well for him since he says that the size of the character got all screwed up. I think his problem is too much restricted to Excel. I want a general way to input infinity character. When I need a poster of it I will paint one. –  sammyg Feb 25 '13 at 23:24
    
@d-man I am using Windows Vista. –  sammyg Feb 25 '13 at 23:24
    
@Sammy It is a duplicate, because regardless of why he wanted the character, the methods for typing one on a keyboard are there in the answers to the question. The answer I linked appears to be different to the one you linked. –  Paul Feb 25 '13 at 23:53
    
@Sammy see my updated answer, should sort you out. –  Peleus Feb 25 '13 at 23:55

5 Answers 5

up vote 1 down vote accepted

Ok, alternative.

What's happening is it's translating to the old windows codes instead of unicode as it's below 255.

What you need to do is go to your windows calc and enter in 221E in hex, then click on dec. It will translate it for you as 8734 in decimal.

Then, with numberlock on, enter ALT + 8734 and you'll get ∞ . It's a bit wierd but sometimes different fields interpret the codes different. For example if I do alt + 8734 here in this box I get ▲. If I do it in google chromes address field I get ∞.

Honestly the descrepency I'm not sure of, but considering I get ý in the google chrome address field by entering in 236, it should fix your specific problem.

share|improve this answer
    
Also, please cite where you get your information –  ekaj Feb 25 '13 at 23:16
    
Google / en.wikipedia.org/wiki/Unicode_input –  Peleus Feb 25 '13 at 23:31
    
I don't have the key EnableHexNumpad. In Input Method I only have the string value Show Status, and I also have the key Hot Keys. –  sammyg Feb 25 '13 at 23:31
    
This could be worth looking into. It looks like this might just do the trick. –  sammyg Feb 25 '13 at 23:43
    
@Sammy: If EnableHexNumpad does not exist, create it with a right click. –  sudo Feb 25 '13 at 23:48

There's always the sneaky way of doing it - google up the symbol, copy and paste. ∞ , then build an autohotkey shortcut. You can get AHK here

share|improve this answer

The infinity symbol is Alt+236. That is what I've typed here. If it's not working with some particular application, it's usually because that particular app doesn't properly support composing characters using the NumPad. But I can't explain why it's not working for you with anything.

One thing to check (or experiment with) is your keyboard setup. From inside the Control Panel, click "Change keyboards or other input methods", then "Change keyboards...".

share|improve this answer
    
So why am I getting ý then? –  sammyg Feb 25 '13 at 23:27
    
No, it's probably not the application I am using. I have already stated in my question that I got the same result in both Excel, Word and Firefox. Has anyone read the question?... kind of makes me wonder. I only took these applications as examples. Again, I only get acute Y when pressing Alt and 236, which is this character right here: ý –  sammyg Feb 25 '13 at 23:38
    
@sammy When I type Alt+236 I get: ∞ Keyboard setup may indeed be your issue. I need to type Alt+0221 to get Ý and Alt+0253 to get ý. –  Xander Feb 25 '13 at 23:46
    
236 is ∞ for me as well. –  Shinrai Feb 25 '13 at 23:50
    
Producing a "ý" is normally accomplished by pressing "alt + 0253". Sammy, what happens if you try that instead out of interest? –  Austin ''Danger'' Powers Feb 25 '13 at 23:57

If you are unsure about modifying the registry and running a newer Windows (I think from Vista upwards), you could type up this little text file

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel\Input Method]
"EnableHexNumpad"="1"

save it as, say »Enable_HexNumPad.reg« and double-click it (using a computer administrator account). It will place a new REG_SZ value into the Registry under HKCU\Control Panel\Input Method. That’s how I do it for new machines, since they come without HexNumPad enabled, unfortunately. Remember to use the NumPad keys (it will probably not work on a laptop without—doesn’t on mine, at least).

Recap: Alt (keep pressed!) NumPlus hexdigit hexdigit hexdigit hexdigit (release Alt) »hexdigit« can be 0..9 on the numeric pad, or a..f on the main keyboard (which again sometimes breaks it due to Alt+a..f often being mapped to functions within a program.)

You can also try: (type the four hex digits) then immediately type (Alt+X), which will work in most of Microsoft’s Rich Text Editors.

For it to work, it might require a logoff-logon (or reboot?) sequence, I can’t remember rightaway.

Oh, and it just might not work with all applications! Unfortunately, not all applications are Unicode-aware! In that case, you’ll get some other weird character. (Hint: Try WordPad.)

share|improve this answer
    
Sammy, from your screenshot »update 3« we see that you have added a new subtree in the registry, NOT a REG_SZ value! Then apparently you set the »standard« REG_SZ WITHIN that new subtree to »1«. Which WILL NOT work. Suggestion: Remove the »folder« called »EnableHexNumpad« again (right-click, delete) and try my little text file above. Then reboot and try all over. Sorry for the hassle. –  Moonbase Feb 26 '13 at 0:27

From the screenshot, I assume you’re not using a German keyboard? If using a German keyboard, you could as well download my Writer’s Keyboard (extends the German keyboard), which would have ∞ as the Shift+AltGr+8 combination … Check the keyboard layout first. And it’s free, of course.

share|improve this answer
    
Is there a 'main' page documenting what it does? Its nice to have a link and all, but it would be nicer to see what it does –  Journeyman Geek Feb 26 '13 at 0:24
    
Also, you actually can and should combine this with the other answer. In general on SE its one answer a question a user even if the two answers cover different things –  Journeyman Geek Feb 26 '13 at 0:30
    
Thanks Journeyman, I think all this »Answer« and »Add Comment« here got me a little mixed up … being only about an hour here. Sorry! Re: The Writer’s Keyboard: Actually a German-Extended standard Microsoft keyboard layout file, created using MS tools, and even using the MS installer. Works on NT, 2K, XP, Vista, 7 and—hopefully—8. Sorry to say, I made it about 6 years ago for myself and never bothered to make a nice page around it … The doc is inside the zip file, as far as I did document it. –  Moonbase Feb 26 '13 at 0:34
    
That looks interesting, but I don't think it's for me. The keyboard has a layout for Swedish. I have not taken the time to compare the German layout but just looking at the picture you linked to I see that some things are the same. I have buttons for Ö, Ä, but not for Ü. Not that I will be using it anyway. Just saying. Just a thought: can you make one for Swedish? =) –  sammyg Mar 16 '13 at 19:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.