Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The last time I used my PC, Explorer was acting really slowly, so I called up the task manager and shut down explorer, expecting vista to restart it automatically. Oddly, that did not happen.

Following that, peerblock began intermittently giving some message about a

i/o error; disk access failure'

which is troubling because it is installed onto C drive. I started panicking because I'd typed up quite a bit that I hadn't saved and, fearing the worst, I attempted to save a new file in notepad++. It seemed successful, so I then continued to save all of my work in progress and rebooted.

Upon reboot, vista immediately began installing an update. When that finished, I attempted to resume my work and found that all of the files I had just saved had been overwritten into zero size files. Some of these files represented more than a year's worth of work.

A file system check did not restore the files, so I tried Easus data recovery and recuva and found that neither were able to locate the previous versions of these files.

Is there any program or tool that can restore the files I just lost?

HT Tune reports 0.0% damaged blocks

share|improve this question
    
Restore from your backup copies. –  Daniel R Hicks Feb 26 '13 at 3:13

2 Answers 2

up vote 0 down vote accepted

This is a really difficult question. You probably can't get back your data which was overwritten as 0's (sorry).

What I would strongly suggest is to start off by making a bit copy of the failing drive as best you can using Gnu DD Rescue. (You will need to boot off a Linux disk to do it, and will need space on another drive to copy to. It can also take a long time, depending on the size of the disk and how badly its failed).

Once you have a copy of the disk, make a second copy of the disk (from the one you got using DDRescue) and attempt recovery on that. You will probably be able to get some of your data back (but not the data overwritten with Zero's) this way.

You might also be able to use something like Photorec to try and recover data from older, deleted versions of your files - if you were using common programs to create your data, ie programs whose layout Photorec can recognise. (It does this without looking at the filesystem, just the raw data. You might get lucky ?)

share|improve this answer
    
Just a note, the files weren't overwritten with zeroes, they were overwritten with zero-sized files. It's just the file pointer that's changed, not the data. –  Hand-E-Food Feb 26 '13 at 4:46
    
In that case, photorec might be able to help you to recover the data in those files if it can identify them. Have you forced a full filesystem check ? Maybe that will help you and/or dump the "now unassociated" files in a "lost and found" directory or equivalent [ depending on your filesystem format ] ? –  davidgo Feb 26 '13 at 7:57
    
how do you force a full file system check? –  Eric Leung Feb 27 '13 at 1:02
    
That depends on your filesystem. If you are using NTFS this is probably something you need to do in Windows (and I don't do Windows). For a Linux ext4 filesystem you would use fsck.ext4 -f /dev/PARTITION or similarly fsck.vfat /dev/PARTITION for a FAT32 partition) –  davidgo Feb 27 '13 at 1:38

You might be able to get lucky with some really expensive forensic data recovery (thousands of US dollars), but it depends how important the data is if you're willing to spend that kind of cash. If you are going to do it, shut everything down right now.

In the lower-cost vein, in addition to the recovery programs you've tried, you can look through the App Data, Local Settings, temp folders and what not to see if you can salvage anything. More than you might think is stored in fragments out there as you work. Find out where NP++ stores temp files and hope you get lucky. But in all likelyhood, you're unfortunately out of luck. Sorry.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.