Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I set a variable in /etc/environment, it only seems to apply to administrators while in sudo su.

How can I get the variables to apply to everyone? Especially when they are in terminal?

share|improve this question
    
Have you checked the mode (permissions) of the /etc/environment file? It should probably be set to 644 (rw–r––r––). –  Scott Feb 26 '13 at 3:36
    
It set to: -rw-r--r-- –  MichaelGuest Feb 26 '13 at 4:06

2 Answers 2

One way to do this may be to add the variables into /etc/.bashrc (assuming everyone is using a bash shell)

share|improve this answer
1  
Um, are you sure that’s the file you mean? Not /etc/profile? –  Scott Feb 26 '13 at 3:52
    
@scott - Yes, I'm sure thats the file I meant, but after googling a bit, /etc/profile is probably better. –  davidgo Feb 26 '13 at 4:10

If you want to setup variables to apply to everyone, the best place is neither /etc/environment nor /etc/profile, because they are system files -- messing them up will give you headaches when you system is upgraded.

Best approach:

  • Create your own files under /etc/profile.d/,
  • Give it a .sh extension
  • make it executable (via chmod 755 file)

That's it. When you need to have similar setting on different boxes, or when it time to do a brand new installation, or any similar situation. Just backup/copy the file over, and you are done for the day.

HTH

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.