Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a CentOS 6 (minimum install or netinstall, I can't remember which) on a virtual machine. I'm trying to install Plone 4.2.4 on it for testing purposes. I have installed all the required dependencies, or at leat I think so.

I run the Plone Unified Installer (I use the --static-lxml option because Plone requires a libxml2 version not present on CentOS)

./install.sh --static-lxml standalone

I get the following error:

Stand-Alone Zope Instance selected

Detailed installation log being written to /root/plone/Plone-4.2.4-UnifiedInstaller/install.log

Root install method chosen. Will install for use by system user plone

Installing Plone 4.2.4 at /usr/local/Plone

User 'plone' already exists. No need to create it.
Skipping libjpeg build
Skipping readline build
Installing Python-2.7.3. This takes a while...
Install of Python-2.7.3 has failed.

Installation has failed.
See the detailed installation log at /root/plone/Plone-4.2.4-UnifiedInstaller/install.log
to determine the cause.

Here's the Plone install log.

I installed Pythonbrew to try to install Python 2.73 using it. I can sucessfuly install Pythonbrew, but when I run pythonbrew install 2.7.3 I get the following error:

[test@plonemachine root]$ pythonbrew install 2.7.3
Use the previously fetched /home/test/.pythonbrew/dists/Python-2.7.3.tgz
Extracting Python-2.7.3.tgz into /home/test/.pythonbrew/build/Python-2.7.3

This could take a while. You can run the following command on another shell to track the status:
  tail -f "/home/test/.pythonbrew/log/build.log"

Patching Python-2.7.3
Installing Python-2.7.3 into /home/test/.pythonbrew/pythons/Python-2.7.3
ERROR: Failed to install Python-2.7.3. See /home/test/.pythonbrew/log/build.log to see why.

Here's the Pythonbrew build log. It's almost identical to the Plone install log(!), leading me to believe the problem lies somewhere else.

share|improve this question
add comment

1 Answer

It looks like the configure script exited correctly and the Makefiles were created. My guess is that you are missing some of the basic development tools, perhaps autoconf. Try installing them with this command as root (source):

 yum groupinstall 'Development Tools'
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.