Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to get iTunes to show all tracks from the same album grouped together.

I've set the album field to the same value for all the tracks, but yet some of them still appear in their own album with the same name.

How do I get iTunes tracks to appear in the same album?

share|improve this question
    
The most common reason I see for this in other media players is that the album artists are different, so that could be the problem here. (I don't use iTunes, hence the reason this isn't an answer, just a guess.) –  Sasha Chedygov Nov 16 '10 at 2:30
add comment

4 Answers 4

up vote 3 down vote accepted

I also had that some times... double check the Info, so that Album, Artist, Year... are all consistently the same.

If you have different Artists, you have to set it to "Compilation"

share|improve this answer
add comment

"but yet some of them still appear in their own album with the same name."

If the "Album" field is set to the same value for all the tracks, the difference must lie elsewhere. In the "Disc Number" field, for instance. On some songs it is set to "1 of1", on some other songs no value has been entered in this field.

share|improve this answer
    
I had the same problem and this disc number/ track number helped. Thanks. –  tnatharik Jan 18 '11 at 6:32
add comment

Select all of the songs at once in itunes, and make sure they are in the order you want. Then right click, hit get info, and under the options tab, make sure part of a compilation is checked and says yes, then check remember position and make sure it says yes as well. Then delete the old songs off of your ipod. Then reselect all of the original songs again, and drag them over to your ipod.

I had a problem on my iphone 3g where the song was showing up under the same album, but was not being grouped with it under the albums tab. After doing this, it is included in the album under the albums tab, allowing me to listen to the entire album uninterrupted.

Hope that helps.

share|improve this answer
add comment

I had several like this that I couldn't make stack regardless of what I changed. What eventually fixed it was selecting all of them, checking them so they are in a compilation and then selecting them all and disabling that.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.