Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When my mac reboots, I would like to have Terminal open in full-screen mode (not full window size). I'm on OS X 10.8.2. How can I configure this?

share|improve this question
up vote 2 down vote accepted

To have Terminal open in full screen when logging in:

  1. Open Terminal, enter full screen (View>Enter Full Screen), then close it.

  2. Open System Preferences>General and uncheck the "Close windows when quitting an application" option:

    enter image description here

  3. Then add Terminal to your login items in System Preferences>Users & Groups:

    enter image description here

Next time you log in Terminal will open in full screen.

share|improve this answer
    
Doing this makes Terminal open in full window size not full screen mode – CommonCents Feb 27 '13 at 16:05
    
Do we mean the same thing with 'full screen'/'full window size'? Full screen is what you get with View>Enter Full Screen. Full window size is what you get when clicking the green button in the top-left corner of the application window. I tested my answer on a Mac running OS X 10.8.2 and worked. – jaume Feb 27 '13 at 16:24
    
Yes, we mean the same thing. The only thing missing from your explanation was found here: superuser.com/questions/543699/… – CommonCents Feb 27 '13 at 16:35
    
Added that to my answer, great you got it working. – jaume Feb 28 '13 at 9:34

If you don't want to enable Resume, you could also set Settings > Shell > Startup > Run command to osascript -e 'tell app "System Events" to keystroke "f" using {control down, command down}'.

In iTerm you could:

  • Select Profiles > Window > Settings for New Windows > Style > Fullscreen
  • Uncheck General > Use Lion-style full screen windows (unless you like the animations for changing spaces, having ⌘H disabled, and not being able to open other windows over full screen windows)
  • Run defaults write com.googlecode.iterm2 NSQuitAlwaysKeepsWindows -bool false if you haven't disabled Resume in System Preferences (there is a bug where the menu bar is always shown in restored full screen windows)
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .