Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just upgraded my system from Red Hat 5.8 to 6.4. Upon issuing the command yum update I get the following message

This system is receiving updates from Red Hat Subscription Management.
This system is receiving updates from RHN Classic or RHN Satellite.
rhel-6-workstation-rhev-agent-rpms                                                                                                                        | 2.8 kB     00:00     
rhel-6-workstation-rpms                                                                                                                                   | 3.8 kB     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package libedit.x86_64 0:2.11-4.20080712cvs.1.el6 will be updated
---> Package libedit.x86_64 0:20090923-3.0_1.el5.rf will be an update
---> Package libffi.x86_64 0:3.0.5-3.2.el6 will be updated
---> Package libffi.x86_64 0:3.0.9-1.el5.rf will be an update
---> Package perl-Test-Harness.x86_64 0:3.17-129.el6 will be updated
---> Package perl-Test-Harness.noarch 0:3.22-1.el5.rf will be an update
---> Package perl-Test-Simple.x86_64 0:0.92-129.el6 will be updated
---> Package perl-Test-Simple.noarch 0:0.98-1.el5.rf will be an update
---> Package portreserve.x86_64 0:0.0.4-9.el6 will be updated
---> Package portreserve.x86_64 0:0.0.5-2.el5.rf will be an update
---> Package python-beaker.noarch 0:1.3.1-6.el6 will be updated
---> Package python-beaker.noarch 0:1.5.3-1.el5.rf will be an update
--> Processing Dependency: python(abi) = 2.4 for package: python-beaker-1.5.3-1.el5.rf.noarch
---> Package python-mako.noarch 0:0.3.4-1.el6 will be updated
---> Package python-mako.noarch 0:0.3.5-1.el5.rf will be an update
--> Processing Dependency: python(abi) = 2.4 for package: python-mako-0.3.5-1.el5.rf.noarch
---> Package python-markupsafe.x86_64 0:0.9.2-4.el6 will be updated
---> Package python-markupsafe.x86_64 0:0.11-1.el5.rf will be an update
--> Processing Dependency: python(abi) = 2.4 for package: python-markupsafe-0.11-1.el5.rf.x86_64
---> Package python-paramiko.noarch 0:1.7.5-2.1.el6 will be updated
---> Package python-paramiko.noarch 0:1.7.6-1.el5.rf will be an update
--> Processing Dependency: python(abi) = 2.4 for package: python-paramiko-1.7.6-1.el5.rf.noarch
--> Finished Dependency Resolution
Error: Package: python-mako-0.3.5-1.el5.rf.noarch (rpmforge)
           Requires: python(abi) = 2.4
           Installed: python-2.6.6-36.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201301301459.x86_64/6.4)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6.i686 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-20.el6.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
Error: Package: python-paramiko-1.7.6-1.el5.rf.noarch (rpmforge)
           Requires: python(abi) = 2.4
           Installed: python-2.6.6-36.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201301301459.x86_64/6.4)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6.i686 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-20.el6.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
Error: Package: python-beaker-1.5.3-1.el5.rf.noarch (rpmforge)
           Requires: python(abi) = 2.4
           Installed: python-2.6.6-36.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201301301459.x86_64/6.4)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6.i686 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-20.el6.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
Error: Package: python-markupsafe-0.11-1.el5.rf.x86_64 (rpmforge)
           Requires: python(abi) = 2.4
           Installed: python-2.6.6-36.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201301301459.x86_64/6.4)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6.i686 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-20.el6.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-workstation-rpms)
               python(abi) = 2.6

I'm not sure what is going on or where to start in tracking down the issue. I think there may be a problem with a repository in /etc/yum.repos.d/. I'm not sure why the message says package_blah.el6 will be updated, package_blah.el5.rf will be an update. Surely el6 will be the update

Also when I try remove python yum remove python.x86_64 I get a very odd error Error: Trying to remove "yum", which is protected

share|improve this question
1  
It doesn't, it says that 1.7.5 will be updated and 1.7.6 will be an update. Your problem is that some packages seem to depend on python 2.4 and you will install 2.6. Is a fresh install an option? –  terdon Feb 27 '13 at 16:13
    
The system version of python is 2.6. A fresh install of red hat? I guess that is possible as I only updated this morning. Nothing to lose –  moadeep Feb 27 '13 at 16:21
add comment

1 Answer

As I cannot comment,I am answering, You may try

#yum reinstall python

before

#yum update
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.