Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've looked in the Java section of the Control Panel, but don't see an obvious way to disable the automatic message balloon that pop up in Windows 7 asking me to update my version of Java. How do I disable them?

share|improve this question

marked as duplicate by Siim K, Dave M, KronoS, Renan, 8088 Feb 28 '13 at 2:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers 3

You shouldn't disable the update notifier. Instead, change preferences for how often you'd like to be notified of newer versions.

At java website you have all the information you need.

http://www.java.com/en/download/help/java_update.xml

After reading the doc, if you still want to disable the notification, do the following:

  1. Start regedit.
  2. Navigate through to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy
  3. Change the value of EnableAutoUpdateCheck to 0 and the value of EnableJavaUpdate to 0.

Also for 64bit users:

  1. Start Regedit
  2. Navigate to HKLM\SOFTWARE\Wow6432Node\JavaSoft\Java Update\Policy
  3. Change the value of EnableJavaUpdate to 0.
  4. Change the value of NotifyDownload to 0
  5. Create a new DWORD of EnableAutoUpdateCheck and set the value to 0.

Done

share|improve this answer

1 - open JAVA control panel by type java in start menuJava

2 - on update tab deselect(uncheck) "check for update automatically" enter image description here

3- Select " Do not Check"enter image description here

4 - all Done!

share|improve this answer
1  
This doesn't actually work. If you go back into the control panel after making that change, you'll see that it doesn't "stick". This is the correct answer: serverfault.com/a/26568 –  Jon-Eric Oct 22 '13 at 15:12
    
Same here, this does not work. I'm not going to downvote because it would be a correct answer if the idiots who distribute the Java weren't busy running it into the ground. –  AaronLS Feb 28 at 2:17
    
This works if you have never installed Java i.e. it uses the one provided by Windows. It stops working when you either install the JRE or JDK. –  cup Jul 6 at 7:35

If changing the notification settings in the Java Control Panel did not help, than it is probably not possible. Check the Update tab of the Java Control Panel. Uncheck "Check for Updates Automatically"

Your best course of action may be to uninstall Java completely if you are not using it. Java is the most widely exploited plugin on a computer and running an out of date version that is plugged in to the browser is very risky. The reason there are so many updates is because it is very problematic and unsafe software to use in a browser.

You can customize the notifications in Windows 7 by clicking the arrow in the Notification Center/System Tray and selecting Customize. You can scroll to the Java icon and change the behavior to "Hide icon & Notifications"

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.