Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got 16GB ram and running Windows 7 64bit, but for some reason I think it's utilizing only 4GB?

If I go into properties it says Installed memory: 16.0 GB, but if under some loads for example starting Dreamweaver, Photoshop and some other programs, a Windows error/notice pops up suggesting I should close some programs to prevent information loss due to low memory. If I open the task manger in that situation and add up all the running processes Memory usage, I always seem to end up at 4GB ram.

Let's say I start Photoshop 4 times, each of it will consume 1GB of the memory, this is when Windows will give me the warning that I'm running low on memory.

In msconfig, the memory limitation is not set.

Is there anything else preventing it from utilizing all of my RAM?

Image of the computer properties window enter image description here

share|improve this question
4  
If the programs/applications you are using are 32-bit, they will still each be subject to a 4GB addressing limitation (and less, practically speaking, because the OS reserves some of that range.) Have you tried a bona-fide 64-bit program and observed this problem? –  Chris W. Rea Feb 27 '13 at 20:48
    
I haven't tried with any explicit 64bit applications, but the applications i'm using won't even reach 4GB at all, what I mean is i'm running multiple applications (let's say I start photoshop 4 times) each of it will consume 1GB of the memory, this is when windows will give me the warning that i'm low on memory. –  Marius Feb 27 '13 at 20:50
1  
Ah; that's more clear. Suggest you edit your question to include that detail. –  Chris W. Rea Feb 27 '13 at 20:55
3  
Can you post a screenshot where it shows Installed Memory and System Type? It is normally the screen you see when you right click on "Computer" from the start menu and go to properties. –  Scott Chamberlain Feb 27 '13 at 21:07
1  
open task manager and select "view", then "select columns", add GDI Objects to list. If you add up all the GDI numbers is it over or near 10,000 when you get the message? –  BroScience Feb 27 '13 at 21:48
show 6 more comments

2 Answers

Go into your BIOS and look for a setting called "memory remapping". Make sure it is on.

share|improve this answer
add comment
  1. Let me know your adobe version, because if those are not latest your issue is normal.

  2. In Photoshop there is an option to control amount of memory and system cache using by only Photoshop.

share|improve this answer
2  
I'm not talking only about Adobe, this happens with any memory intensive application, I could aswell start a game multiple times and it does run into the same problem. –  Marius Feb 27 '13 at 20:51
    
yes Mrius and chris are right, but I do utilize Photoshop+premier to use more than 12gb of ram when running 64bit version of both. all in cs5 edition –  Kaveh Feb 27 '13 at 20:54
1  
@Marius - this was still a valid suggestion though. You mentioned multiple Adobe products and Adobe allows a limit to be placed on the memory used cumulativly across all Creative Suite products in use. Your wording of your question made this appear to be a possibility. –  AJ Henderson Feb 27 '13 at 22:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.