Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I switch computers using my KVM Windows makes a strange clicking sound. It's not hardware - it scales with the Windows volume level. It's not the Device Disconnect or Connect sounds - I tried setting the sound scheme to "No Sounds" to test. The Volume Mixer says that the clicking sound is coming from "System Sounds," but I don't see anywhere else the sound might be coming from.

Does anyone know how I can eliminate this extremely annoying noise?

EDIT: The KVM is a StarTech 2 Port USB DVI Cable KVM Switch with Audio (SV215MICDVIA), though I encountered the same problem with an IOGEAR 2 Port USB Cable KVM Switch with Audio and Mic (GCS72U).

share|improve this question
    
Do you have one of those higher-end KVMs that also routes the audio from 2 different PCs to your speakers? –  Austin ''Danger'' Powers Feb 27 '13 at 23:53
    
@Dan thanks, should have mentioned that - it's a "StarTech 2 Port USB DVI Cable KVM Switch with Audio (SV215MICDVIA)". Editing question. –  Jonathan Chan Feb 28 '13 at 0:04
    
    
can you upload a recording of the sound to ge.tt a program like audacity or total recorder or even sndrec32 can record what would come out the speakers. –  barlop Mar 6 '13 at 10:23
add comment

4 Answers

Thanks for adding the KVM model. I just wanted to check your KVM had audio switching too (which it does).

It sounds like the audio switching component of the KVM could be introducing some interference as it switches the audio input from one PC to the other.

It's going to be a very low-level problem: the KVM itself is most likely causing what you're hearing. Using a different model KVM might be the only solution. Also the amp in your speakers may be more susceptible to producing that clicking sound when used with this particular KVM, so using different speakers is the other solution.

I really doubt the computers themselves are at fault here.

You could probably connect 2 different audio devices altogether and still hear that sound- or maybe even disconnect the audio cables from the PCs, and find that switching inputs could still cause a sound. It's worth a quick 30 second test for sure.

share|improve this answer
2  
There is a constant static sound in the speakers as well which I'm trying to fix, but as for the clicking sound I can actually see Windows display it in the Volume Mixer. If it's being shown there, isn't it being caused by software running in Windows, instead of just hardware? –  Jonathan Chan Feb 28 '13 at 1:58
    
What's your OS, and does it happen when you switch both directions? –  Austin ''Danger'' Powers Feb 28 '13 at 2:29
    
It only happens when I switch from my Linux computer to Windows. –  Jonathan Chan Feb 28 '13 at 2:58
1  
See what happens when only your Linux system is connected when you switch over, then try again with only your Windows machine connected. You need to start taking some variables out of the equation so you can narrow it down. –  Austin ''Danger'' Powers Feb 28 '13 at 5:42
    
How can I switch over to Windows when only my Linux system is connected? It's certain that the sound is being emitted by Windows - the sound is being registered by Windows' sound mixer, so it is impossible for it to be a hardware problem unless the KVM is somehow writing to the memory of my computer through the audio jack. Switching over from Windows to "Linux" and back when Linux is not connected causes the same sound. –  Jonathan Chan Feb 28 '13 at 23:52
show 1 more comment

Could it just be the standard sound Windows plays when you connect a new device?

After all, every time you swith the KVM you phisically connect/disconnect the keyboard/mouse to the computer. This would explain why you hear it only when you switch into Windows and why you see the sound in the Windows mixer.

To check if this is the case, open Control Panel > Sound (and Audio Devices in XP) > Sounds tab and choose (None) as the sound for the following Windows events:

  • Device Connect
  • Device Disconnect
  • Device Failed to Connect

Alternatively, just choose the No Sounds scheme to silence all Windows sounds. Before doing so, you may want to save in a new scheme any customization you may have made to the default one (if any).

share|improve this answer
    
I already tried this - didn't work, unfortunately. –  Jonathan Chan Mar 25 '13 at 19:31
    
Not even with the No Sounds scheme? After selecting it, can you confirm that no event has a speaker on its side? Especially the application defined ones at the bottom of the list. –  Danilo Roascio Mar 25 '13 at 23:11
    
Yes, even with No Sounds. I checked every event to make sure :( –  Jonathan Chan Mar 26 '13 at 23:51
add comment

The only thing I can think of is if the KVM also has a jack plugged into the microphone (audio in/aux in) port of your sound card and interference from the KVM is causing the click. Disable the audio in for troubleshooting.

There is one other possibility actually. I run a SoundBlaster X-Fi Fatality Champion edition at home hooked up to 7.1 Soundblaster surround sound speakers. When the sound card initiates when the computer turns on, I get an almighty crack which is also detected in the volume mixer. Like a sudden release of static build up, that sort of crack. Anyway, now I think about it, it hasn't happened since I updated the audio drivers in windows 7. They released one's compatible with windows 8 recently. Apparently the only change was to make it windows 8 compatible, but the problem I was having with the front panel for volume control are fixed and the cracking has stopped, so you might just want to update your drivers. Do a full uninstall first rather than an upgrade install.

share|improve this answer
add comment

The sounds are from Windows HPD - Hot Plug Detect- flag. Windows 7 and Windows 8 both are continuously checking the status of connected devices not limited to the keyboard and mouse, but also display monitor and all other I/O devices such as speaker or microphone.

Unfortunately , if you do not use DDM class of KVM switch, your KVM switch will trigger the HPD error USB devices or audio devices. If you do not have KVM support full time EDID feeding of connected monitor, you will still have the HPD error for the video part.

So, combining both DDM and Full-time EDID feeding is the only solution to stop the HPD error and stop the error sound feeding.

share|improve this answer
    
This seems the most likely. Is there really no option to disable the notification for this flag in Windows? Thanks. –  Jonathan Chan Mar 25 '13 at 0:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.