Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to boot a live distro on a VAIO YB35AL ultrabook. It doesn't have an optical drive, so I'm using a USB flash drive, and deploying the Linux ISOs to it using either unetbootin or Universal USB Installer.

With unetbootin, I get presented with a menu listing several boot options depending on the distribution I'm trying to boot, with a ten second countdown timer until it boots the Default entry. However, if press Enter to skip the countdown, or if I press an arrow key to choose another option, the laptop freezes instantly. If I let the timer expire, it starts booting, but freezes right after loading ubninit or displaying the SYSLINUX info depending on the distro (basically after loading initrd, I think). If I leave the laptop running after it freezes, it starts to overheat, probably due to high CPU load.

With Universal USB Installer, it simply freezes on boot, without the menu.

This behavior occurs regardless of which distribution I'm trying to boot. I've tried Knoppix 7.0.4, Fedora 18, Backtrack 5r3 and GParted Live (all of them LiveCD ISOs).

To eliminate possible causes, I scanned the USB drive for errors under Windows 8 and it came out clean. It may be worth mentioning that the laptop uses UEFI rather than BIOS and I'm not sure if all the distros I'm trying support UEFI. However, Fedora certainly does, and it's not working.

share|improve this question
    
Have you tried with UEFI disabled? Some laptops have reported problems with UEFI + Linux still. –  Breakthrough Feb 28 '13 at 2:08
    
I had no idea it could be disabled. I managed to boot Knoppix using a different USB drive, but when I'm done I'll try the previous one again with UEFI disabled, just out of curiosity. –  jSepia Feb 28 '13 at 2:24
add comment

1 Answer

The USB drive may have been defective after all. After stumbling upon this question, I decided to try another one (a Sandisk Firebird; the previous one was generic) and it worked. I was able to run Knoppix.

share|improve this answer
    
I still don't know why I was unable to boot from the previous USB drive, so if anyone has a more specific answer, feel free to post it. –  jSepia Feb 28 '13 at 2:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.