Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just upgraded to Windows 7 Ultimate 64-bit. I had an issue during installation; after setup rebooted instead of going to the 'Completing installation' screen I just got a blank screen. I eventually(!) figured out that this meant 'un-plug your second monitor to proceed'. When I did this, installation completed in a snap and everything runs fine. However, whenever I plug my second monitor into my PC, it gets no signal, the primary monitor removes all windows. Icons, the taskbar and the cursor just shows the desktop wallpaper.

I'm running a GeForce 8800 GTS 512 MB, with the latest drivers (197 IIRC). The monitors are identical, and both plug into DVI sockets on the graphics card, the only difference is I connect one using a straight DVI cable and the other using a VGA cable and a VGA-DVI converter. It's the DVI cabled one that has the issues (if I plug it in by itself it gets no signal). Everything was working fine before I upgraded to Windows 7 (I used to run Windows XP SP2). How can I fix this problem?

share|improve this question
1  
Have you tried switching connectors? It is seeing the wrong 1 as primary. –  Henk Oct 15 '09 at 20:03
    
Are you using a Samsung monitor? I ran into a similar problem with Vista using a Samsung 226BW and an ATI 4850. ATI/Microsoft never fixed it, so I went back to XP. That issue only happened if I used a DVI cable, and a single monitor, though. –  skypecakes Jan 6 '10 at 7:30
    
This solved a problem I was having in a different question - thanks very much! –  Neil Barnwell Feb 4 '11 at 15:06

3 Answers 3

I have been trawling the Internet for ages looking for the solution as I had the same thing. Boot up in safe mode and all works fine through DVI. Boot up normally and you see as far as loading Windows 7, or whatever OS you are using, then as soon as it gets into windows you lose the signal. Also everything works fine if I use a DVI>VGA adapter, but the image is significantly worse than if I use DVI digital. Anyway, to cut a long story short the problem is that through some mechanism (in my case I had a GeForce FX card failure that caused this) the EDID data on the EEPROM chip in your monitor has become corrupted. You will need the full registered version of a tool called PowerStrip made by EnTech Taiwan to attempt to correct this. The trial version doesn't have the feature required to attempt this.

When it's installed and registered, shutdown your PC. Make sure you have connected the faulty monitor only using the DVI digital cable to the graphics card. Disconnect other monitors if you are using more than one. Boot up into safe mode (keep pressing F8 while booting up to get the option to boot into safe mode).

Start up PowerStrip and right click on the System tray icon. Go to Options > Monitor Information. It will probably just say the manufacturer is Microsoft and the Model ID is "Default Monitor" or something instead of your actual monitor details. At the bottom where it says Options, select the option to Update EDID. Follow the instructions to detect an EEPROM device, and hopefully it will detect you have corrupt headers and it will ask if you want to correct them. Select yes and follow the prompts. At the end it will ask you to restart. Hopefully you should be all good after the restart.

I used version 3.83 of PowerStrip for this and originally received an error saying "An EDID EEPROM was not found" when scanning for the EEPROM, but this is because this version didn't have support for updating the EDID on a Geforce 275. I tried the same procedure on a GeForce 6600 GT on my old PC and it worked perfectly.

If this doesn't sort out your problem you can try and locate a full EDID export for your monitor and use the same procedure to upload it, but there are some additional steps you need to know doing it this way, so read the full article that helped me resolve this at http://blog.komeil.com/2008/06/fixing-edid-dvi-monitors-no-signal.html.

share|improve this answer
    
I'm having the same issue, but when I boot in Safe Mode and launch PowerStrip (purchased version) the icon doesn't show up in the system tray. What step am I missing? –  rie819 Nov 2 '12 at 19:10

Don't know if you found a solution to your problem, but I just wrestled with something similar with Windows 7 32-bit.

Under XP, both monitors connected via DVI cables worked fine. After installing Windows 7, both monitors would display the POST screen, and "Starting Windows" screens, but then only one would display the login screen and desktop.

I installed the latest NVIDIA drivers for my card, but that didn't help. Quite a few forums suggested unstalling the latest Vista 32-bit drivers rather than the Windows 7 drivers, so I tried that and it worked. You can find archived NVIDIA drivers here. Be sure to specify "Windows Vista xx-bit" as the OS or you won't see the Vista drivers.

Also, when I installed the Vista drivers the install dialog said "NVIDIA Windows 7 drivers", but the driver version and NVIDIA control panel are the correct Vista versions. Weird.

Hope this helps.

share|improve this answer

You need to run the nVidia Control Panel. In there, you will find 'Run Multiple Display Wizard'. This will guide you through getting both of your screens working they way you want.

If you have the control panel installed, you should be able to find it under Start> Search box for 'nvidia control panel'. If not, you'll need to download it from http://www.nvidia.com.

share|improve this answer
    
There's a 'Set up multiple displays' option in the Nvidia Control Panel, however it only shows the VGA connected monitor. If I plug in the DVI connected one, the VGA screen reverts to just the desktop, so I can't actually configure anything in there... –  user99 Oct 15 '09 at 18:01

protected by Diago Oct 12 '10 at 9:56

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?