Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Media Center on a Vista computer, and some programs are in 4:3 format while others are 16:9 -- even on the same channel. It annoys me that I have to manually switch format all the time, using the "zoom" function in MCE, while any modern TV can recognize black bars and adjust the image accordingly.

This should be so simple, yet MCE can't do it!
Is there a tool or an add-on that can automatically select the proper zoom?

Update:
My display is 16:9. Currently on 16:9 unzoomed, there's a black frame on all sides -- WTF?
--> What I want to achieve is:

  • 4:3 images should not be zoomed by default (black bars left and right remain)
    but may be zoomed whenever I want.
  • 16:9 images are zoomed to fit my 16:9 display.

Details:
There's no monitor and no TV attached. Instead, there's an Acer H5350 DLP projector connected directly to the installed Nvidia card's HDMI output at a resolution of 1280x720 at 60 Hz. The graphics card is using updated Vista drivers. There's no driver used for the projector itself; it simply accepts the HDMI signal.

Update 2010 and "solution":
I've now installed Windows 7 on the exact same machine, and I've discovered the problem: with Win7 I can also receive digital TV, and MCE correctly zooms when the show on a digital channel is 16:9! So the root cause is that the computer always receives a 4:3 signal when tuned to an analog channel -- even when the current show appears to be 16:9 then it is in fact still a 4:3 image with black bars over and under the show.
Summary: MCE can detect 16:9 on digital channels only, and will zoom these correctly. MCE cannot detect 16:9 on analog channels. I still need a solution for that.

share|improve this question
    
I'm not sure what you mean, you actually want the 4:3 image zoomed to fill out the entire screen? –  Lunatik Oct 16 '09 at 5:22
    
Added details above, should be clearer now. –  Torben Gundtofte-Bruun Oct 16 '09 at 5:35
add comment

3 Answers

up vote 0 down vote accepted

If you have a 16.9 display - any 16:9 content should fill your screen, and any 4:3 content should have black bars on by default. If you press the i button on your MCE remote (I think a right mouse click will also do the same), it will bring up an option to adjust the aspect ratio. You just need to select the one that says 'default aspect ratio' - I believe it's option 1 but I can't remember off the top of my head.

You should also make sure that MCE is setup correctly to display in 16:9 - you can do this by running the setup wizard again by going into tasks and settings. You can select various options to do with your tv, such as tv type, and aspect ratio.

share|improve this answer
    
This is exacly how I use my Media Center, and I did perform the wizard. So I would expect 16:9 to fill the display, even in the cases where a channel is broadcasting an 4:3 signal (bars on the sides) that shows a 16:9 image (bars on top&bottom) = bars all around should be intelligently removed... As it is, I have to use that "i" menu to change the zoom setting from default ("1") to wide ("2") all the time. I never use the settings "3" and "4", not sure what they're good for. –  Torben Gundtofte-Bruun Oct 16 '09 at 14:32
    
I use 3 quite a lot. They are good for different image sizes such as 16:10 and others –  kevyn Oct 19 '09 at 8:18
    
It turns out that this is correct. My problem was that all content is sent as analog 4:3 even when the movie was 16:9 within that 4:3 format. MCE can't intelligently zoom, but it always uses the format of the broadcast. I'm now able to receive digital content which is broadcast in 16:9 and MCE correctly shows that full-screen on my 16:9 display! So the zoom feature is only needed when watching 16:9 movies within the analog 4:3 format. –  Torben Gundtofte-Bruun Jan 30 '11 at 7:11
add comment

Apparently there is no solution when the display is not a monitor but is a projector.

The only other answer given didn't solve the issue... so it would be wrong to accept it. I'm putting this comment in as an answer because if I don't pick any answer as correct then I get a poor rating... which would also be wrong, because I mark correct best answers accordingly - when I can.

share|improve this answer
    
Note: I edited the question to include "Update 2010 and solution", which describes the current state of the matter. –  Torben Gundtofte-Bruun Aug 17 '10 at 14:00
add comment

@torbengb : Ideally what you expect should happen by default. I have a Widescreen 16:9 TV and I see the following behaviour at Zoom 1

  1. Movie content: Usually at 2.35:1. This appears with black bars on top and bottom. There are no black bars on the sides. This is expected behaviour.

  2. Recent TV Shows : Let us take House/Heroes for instance. These are broadcast at aspect ratio of 1:85:1. On a properly formatted 16:9 TV, this should completely fill up the entire screen with no black bars on any side.

  3. Older Fullscreen content (4:3) : This should fill up vertically while there are black bars on the sides. You can then use any of the zoom setting to fill the screen. I use Zoom 4 for that.

The above is the behavior I see by default. If you don't see the behavior, I think it has to do with the monitor settings.

THe following info should help me help you 1. TV Type : 720p 1080p. What is the input type/scan mode you are using. The model no. should help me narrow down. 2. Desktop Resolution: What is the resolution and refresh rate you are using? Exit 7MC and then look at the resolution setting. 3. Video card config: What is the Video card. How is the TV connected? DVI->HDMI converter? Direct HDMI or VGA?

Ta

share|improve this answer
    
Kiran, thanks for your details; it's good to see that it can work as I want. I added details about monitor etc. in the question above. –  Torben Gundtofte-Bruun Nov 2 '09 at 19:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.