Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am installing W7 Ent on an LG R580.

I am working with a valid ISO (installs perfect on other systems).

During the installation, before the installation window, the process hangs, and I get a black, cmd.exe screen with the following:

Select Administrator: X:\windows\system32\cmd.exe
Microsoft Windows [Version 6.1.7601]

with a prompt for: X:\windows\system32

My keyboard at that time only prints capital letters with '^' before each.

enter image description here

Only thing that I am able to do is reboot.

In the bios, I tried to disable USB Legacy ( thinking the problem is with my DVD ) - did not help.

share|improve this question

4 Answers 4

Check your keyboard. Maybe you have a stuck key.

share|improve this answer
I tried with an external USB keyboard - same results –  Saariko Feb 28 '13 at 15:12
what happened if you close this windows with mouse? –  Kaveh Feb 28 '13 at 21:02
System restarts –  Saariko Mar 1 '13 at 5:07
any chance for bios update? –  Kaveh Mar 1 '13 at 5:51

^X in the terminal usually means that the control key is being held. x:\ is the ramdrive that the installation OS is being loaded to, so somthing is definitely off if you are seeing prompts to it.

Try a memory scan with the MS RAM diagnostic tool on the windows disk, and make sure win7 likes your ram (I've had a few boxes that had install issues until I replaced the ram; Win7 seems more picky about ram sticks that other OSs; these all ran vista and ubuntu fine).

share|improve this answer
Thanks - Windows Memory Diagnostics - passed successfully INVC/LRAND/Stride/WMATS/WINVC - all ok –  Saariko Feb 28 '13 at 15:17

I also had same problem I replaced my motherboard, ram and processor. While installing win 7 It always ended with cmd.exe..but then I noticed that my contol key was stucked in keyboard like it was held continuously. I corrected the position of key and problem solved everything was working fine installed win 7. Wish you luck.

share|improve this answer
This is just confirmation that the @Kaveh answer worked for you. It isn't an answer. –  fixer1234 1 hour ago

I had a similar issue. Every time I tried to boot from USB or DVD to install Windows 7, I would get a command prompt. When I tried to type, it would type wierd characters like ^x or ^d. I even tried with an external keyboard but it did not help.

Based on this article, I removed the laptop keyboard and connected an external one. Everything is working now. I guess it was a bad keyboard.

Thank you and hope this helps someone in the future.

share|improve this answer
This is just confirmation of the @Kaveh answer. It doesn't contribute a new solution. –  fixer1234 1 hour ago

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.