Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a VPN client configured for using PPTP under Ubuntu 9.10 (the alpha version, but fully up to date). The configuration has everything enabled except for EAP (I found I had to uncheck that to make it work).

It worked fine until Tuesday of this week. It now fails with a message: "VPN Connection Failed".

The message in /var/log/messages when it worked on Tuesday is:

Plugin /usr/lib/pppd/2.4.5//nm-pptp-pppd-plugin.so loaded.  
pppd 2.4.5 started by root, uid 0  
Using interface ppp0  
ppp0 <--> /dev/pts/2  
CHAP authentication succeeded  
MPPE 128-bit stateless compression enabled  
local  IP address XXX.XXX.XXX.XXX  
remote IP address XXX.XXX.XXX.XXX  
primary   DNS address XXX.XXX.XXX.XXX  
secondary DNS address XXX.XXX.XXX.XXX

Now it has changed to:

Plugin /usr/lib/pppd/2.4.5//nm-pptp-pppd-plugin.so loaded.  
pppd 2.4.5 started by root, uid 0  
Using interface ppp0  
ppp0 <--> /dev/pts/3  
Modem hangup  
Connection terminated.  
Exit.

I'm using Ubuntu 9.10 alpha; I'm using the standard network-manager applet to configure it (but have also tried kVPNc and manual configuration). The VPN is working fine-- I can connect to it using an XP virtual machine running on the system.

share|improve this question
    
Have you solved the problem? –  user17859 Nov 28 '09 at 21:40
    
Yes-- the key was to edit VPN, click on advanced, in the PPTP Advanced Options dialog, unselect "EAP". –  davesnyd Jan 5 '10 at 13:27
    
Davesnyd - awesome that you figured out the problem; could you please write that up as an answer to your own question, and accept it? Thanks! –  pbr Jan 6 '10 at 21:36

2 Answers 2

up vote 2 down vote accepted

The key is to edit VPN, click on advanced, in the PPTP Advanced Options dialog, unselect "EAP".

share|improve this answer

Not really an answer, but this may be related: http://superuser.com/questions/91009/vpn-pptp-connects-intermittently-on-mac-os-x

(I can't seem to be able to make comments, I guess I don't have enough karma yet, so, there).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.