Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hey guys I have made a blunder. While i was playing with cinnamon settings I set the font size to 990 from the font icon available in cinnamon settings. Now I cant use any applications because of the font. It garbeles the whole screen. I cannot redo it cos when i somehow manage to open cinnamon settings I cant see the font icon, because of the font size and I even if i maximize that window I cant see the font icon. I can see up to icon themes that's it. Now what to do, Is there any way of setting things to normal. I tried setting cinnamon settings to default but did not work. Now what to do? Is it possible from terminal?

share|improve this question

migrated from Feb 28 '13 at 15:35

This question came from our site for professional and enthusiast programmers.

any answers? does someone know where to ask help apart from SO – user2111006 Feb 26 '13 at 17:53
This question would be better posed at SuperUser. PS. Addressing your question to "guys" might make women feel unwelcome to answer! – ptomato Feb 26 '13 at 21:04

You can change Cinnamon/Gnome settings from terminal using gsettings command. You will need to know the schema and key for the setting you want to change. For instance, to change the titlebar font:

gsettings set org.cinnamon.desktop.wm.preferences titlebar-font 'Sans 10'

You can also inspect values by changing "set" to "get" and omitting value parameter like so:

gsettings get org.cinnamon.desktop.wm.preferences titlebar-font

Most changes via gsettings (including UI fonts) are reflected immediately; however, a few may require relogin. I recommend full relogin over Cinnamon restart because changes via gsettings and restart don't always play well together (sometimes resulting in cosmetic glitches...apps disappearing from panel and so on).

share|improve this answer

You must log in to answer this question.