Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After some update and reboot, X fails to start.

I don't get any errors or warnings from the console, after the last service has started, nothing happens. I can then switch to any terminal I'd like, log in and start X with startx. This works perfectly fine. Prior to this there doesn't seem to be any attempt to start X (I removed the logs in /var/log/X* and rebooted, no logs were then generated after I logged in).

I'm now running 3.5.0-17-generic on Linux Mint 14 Nadia (XFCE). I'm using the proprietary Nvidia drivers (although bear in mind X starts perfectly fine with startx).

How can I make X start automatically again? What is the reason I experience this behaviour from the system?

Edit: I can add that I've tried to reinstall the proprietary Nvidia drivers (and they installed successfully), I get hardware acceleration and everything seems to work fine after I've started X with startx.

Second edit: I have S30mdm in /etc/rc2.d/ which points to /etc/init.d/mdm

share|improve this question
    
What is the output of cat /proc/cmdline? – Salem Mar 1 '13 at 0:23
sudo mv /etc/profile.d/infinality-settings.sh /etc/infinality-settings.sh
sudo chmod a+rx /etc/infinality-settings.sh

To .bashrc, add:

# INFINALITY FONT RENDERING CONFIG
. /etc/infinality-settings.sh
share|improve this answer
1  
Can you please explain what the code does? – slhck Sep 24 '13 at 10:26
    
To make infinality started after mdm. I use this way to workaround this problem when I was using mint15 MATE – Rangi Lin Dec 1 '13 at 10:29

In some occasions Infinality font rendering can cause problems when loading the Display Manager.

http://forums.linuxmint.com/viewtopic.php?f=208&t=136307

If you have infinality installed and reconfiguring mdm doesn't works, try to:

sudo apt-get remove fontconfig-infinality

you can also reconfigure mdm as follows:

sudo dpkg-reconfigure mdm

this way it won't be necessary to install mdm again, task that may become hard

share|improve this answer

Fixed this issue with:

apt-get remove mdm
apt-get install mdm
share|improve this answer

I had this exact same problem, and none of the solutions here worked me. After many hours of struggling, and logs showing no errors, I found that my problem was (surprisingly) the result of an unrelated syntax error in /etc/profile.d/myscript.sh. Fixing my script fixed the issue for me.

share|improve this answer

So far, the best answer I've found, in the case of versions of Mint based upon Ubuntu 14.04 (17.01 through 17.03) is to apt-get remove mdm, but NOT to reinstall it. It's a lousy, terrible solution, and it doesn't "solve" the problem, exactly, since none of the forgoing has worked, but, it does leave you a workable system. The system will boot to the "LM" logo "splash" screen and just seem to hang there. Simply press "alt F1" to get a command-prompt (a useful thing to have in my book. You can do some pretty handy system maintenance-type things with that command-prompt!). Then, login at the command prompt, and type "startx". X will start properly, even though MDM is missing.

I know this solution is not a real "solution", but it sure beats an unbootable system that never arrives at any sort of prompt, which is what I ended up with several times while trying to troubleshoot this silly problem.

For what it's worth, it appears that this problem is caused by NOT using the GUI updater "Update Manager", and being stupid and lazy and using "apt-get update" from the command-line, which I did. (The Update Manager has an annoying habit of allowing one to install only one package at a time. One can batch all desired packages into one update command from the command-line, which I tend to prefer. I don't know why I didn't just use Synaptic. Oops.)

Will try to post later if I find the root cause of this particular issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.