Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed Chromium OS (Hexxeh's vanilla build) on my 16 GB flash drive.

Later on, when I tried to format it, it was showing a total space of 1 GB. I tried deleting partitions in disk management, but I was only able to delete some of them. It was then showing free space of 16 MB.

For one partition, when I tried to format it, I got the following error:


error message

An unexpected error has occurred. Check the System Event Log for more information on the error. Close the Disk Management console, then restart Disk Management or restart the computer.


The following images show the partitions that I cannot delete:

enter image description here
enter image description here
enter image description here
enter image description here

What can I do to reclaim the full space of my flash drive?

share|improve this question
    
Can you tell me the Brand of you penDrive..? – SaviNuclear Mar 1 '13 at 10:55
    
HP flash drive! – Manoj Kumar Mar 1 '13 at 15:37

The disk most likely needs to be cleaned. Use the command line utility 'diskpart' to simply just wipe clean the entire device.

DISCLAIMER:

It is recommended that you use the Diskpart utility cautiously because Diskpart enables explicit control of partitions and volumes.

From Run: diskpart

RunDiskpart

DiskPart

1.list disk

Pay Attention Here What disk do you want to clean?

2.select disk # 

Replace # with the disk you're 100% sure you want to clean.

3.clean
4.create partition primary
5.select partition 1
6.active
7.format quick fs=fat32
8.assign
9.exit

See MS article here for more info: http://support.microsoft.com/kb/300415?wa=wsignin1.0

share|improve this answer
    
on step 4 i get this error, No usable free extent could be found. It may be that there is insufficient free space to create a partition at the specified size and offset. Specify different size and offset values or don't specify either to create the maximum sized partition. It may be that the disk is partitioned using the MBR disk partitioning format and the disk contains either 4 primary partitions, (no more partitions may be created), or 3 primary partitions and one extended partition, (only logical drives may be created). – ViVekH Jan 12 at 11:57

I ususally solve those strange situations with usb dongles with the

HP USB Disk Storage Format Tool

you can find it on Google

share|improve this answer
    
Thanks, this registry trick solved the problem.Anyways thanks for the answer.!! answers.microsoft.com/en-us/windows/forum/windows_7-hardware/… – Manoj Kumar Mar 1 '13 at 15:59

Download Rufus and click on "FreeDOS", then it will wipeout and then format it the normal way to make it working as usual. - LordXuran

share|improve this answer

protected by bwDraco Nov 9 '15 at 22:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.