Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have rather peculiar problem. I run a small local network with a dedicated Bind9 DNS server. All hosts are in an invented .lan TLD. I use soemthing like service.mydomainname.lan for addressing several services, e.g. mail, fileservice, etc. Everything works as expected with one single exception, which is rather odd. When I try to access home.mydomainname.lan, every web browser on Mac OS X tells me that it cannot resolve the host name. Other host names like mail.mydomainname.lan work perfectly. The strangest thing is that the system happily resolves the name when I use the "host" tool in a terminal. I tried to flush the cache with dscacheutil, no change. This behaviour started very recently with no particular reason. I did not change the DNS configuration, nor did I change anything on DHCP, the router or the Mac OS X machine.

Does anyone have an idea what is happening here and how I can fix it? This is really annoying, because it happens to be one of my most important services.

Thanks

share|improve this question

1 Answer 1

I found a solution here on Ask Different. After trying that launchtcl magic, DNS worked again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.