Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Debian "server" (old desktop that's just always on) running CUPS 1.4.4, a Gentoo desktop with CUPS 1.5 (I think), and a laptop with Arch Linux and CUPS 1.6.1.

On the Debian box (the server where the printer is), I have "Share printers connected to this system" and the "CUPS" protocol selected.

On my Gentoo desktop, I have the "Show printers shared by other systems" option and the "CUPS" protocol selected, and it prints just fine.

On my Arch Linux Laptop, however, there is no "Show printers shared by other systems" option. How can I get CUPS 1.6.1 to print to the CUPS 1.4.4 server?

According to Arch Linux's wiki, I need to use cups-browserd and Avahi (or something), but I can't figure out how to set it up.

share|improve this question
add comment

2 Answers

This seems to be a recognized bug with CUPS 1.6.x itself. There is a discussion and workaround for Ubuntu here

Hopefully this will be applicable to your situation or at least advance improve your chances of finding a solution.

share|improve this answer
    
Arch Linux also mentioned that avahi was needed, but I don't know how to set that up. I'll try some of the suggestions there and see what happens. –  Rocket Hazmat Mar 7 '13 at 14:18
    
This didn't seem to help. The config files on my client were correct. The server is running CUPS 1.4, and the client (running CUPS 1.6) can't see its printers. –  Rocket Hazmat Mar 9 '13 at 19:55
    
Have you reconfigured the CUPS 1.6 client? The CUPS 1.4 system is the smaller part of the problem. –  washbow Mar 10 '13 at 2:43
    
I tried to configure the client, but it didn't seem to do anything. The settings that were suggested I add were already there. –  Rocket Hazmat Mar 10 '13 at 4:30
add comment

If the version of your cups-client is 1.6 or newer, then it will default to IPP version 2.0, which older versions of cups do not understand. To solve this, you need to specify the IPP version in your /etc/cups/client.conf, f.e. like this:

ServerName 192.168.0.1/version=1.1

HTH.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.