Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell T3400 PC with an Intel Matrix Storage controller and two disks which were in a RAID-1 configuration. I took out one of the disks and installed Linux on the other disk, breaking the RAID configuration in the process (i.e. I installed directly on /dev/sda, not on the imsm volume). I did this on purpose because I don't want Intel fakeraid any more, I'll use Linux's native mdraid format.

Now the computer won't boot with this disk connected. I get as far as the BIOS screen, but after that I get a black screen with a blinking cursor. This is the time where the Matrix Storage setup prompt should appear, so I suspect that the controller firmware is locking up during its initialization.

I can't even reach the BIOS setup with the disk plugged in. If I unplug the disk, I can reach the setup, but I have no option to invoke the Matrix Storage setup or to disable it altogether (I can only choose between RAID-else-AHCI, RAID-else-ATA, or RAID-else-abort).

How can I make this disk usable in the PC? Preferably without erasing the data on it (I can take it out and zero it fully, and even use another Linux PC to rebuild an imsm volume, which hopefully should work, but I hope it doesn't have to come to that).

I put the disk in another machine and noticed that the last sector (last 512B) begins with Intel Raid ISM Cfg Sig. 1.1.00. I zeroed it out. That didn't help. I went further back and found two other occurrences of Intel in the last 4MB of the disk, located 161 and 323 sectors before the last sector. I zeroed out the last 400 sectors of the drive. Still no dice.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.