Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have switched SATA controller mode from IDE to AHCI, and my Fedora (the latest release) doesn't boot now. I'm not surprised by this fact alone, but I am surprised with the message I'm getting:

BOOTMGR IS MISSING

Which, I believe, is BIOS message, not OS message, so Fedora doesn't even start booting (unlike Windows). Why am I'm getting this message, and is there any way to enable AHCI without reinstalling Fedora from scratch?

share|improve this question
    
What do you want to do, and why? "If it ain't broken, don't fix it" is sage advise... –  vonbrand Mar 1 '13 at 17:57
    
@vonbrand: I want NCQ. –  Violet Giraffe Mar 1 '13 at 17:59
    
What happens if you switch back to IDE? –  harrymc Mar 6 '13 at 19:11
    
@harrymc: it boots fine in IDE mode. –  Violet Giraffe Mar 6 '13 at 20:57

2 Answers 2

up vote 2 down vote accepted
+50

Info taken from here.

You need to recompile the kernel, if you compile with built-in support then you're safe, but mkinitrd will only take the modules that are needed to boot the running kernel - meaning that unless you can boot the machine into Fedora with AHCI on and then run mkinitrd, it won't take it by default.

You can use the --preload option to manually specific modules though, so you could always try turning AHCI off, booting Fedora, making your custom image:

mkinitrd --allow-missing --preload=ahci --force-scsi-probe /boot/initrd-`uname -r`-custom `uname -r`

Then reboot, enable AHCI and during the GRUB bootup menu edit the "initrd" line to load the custom image you just created. When that's done, reinstall the latest kernel (or yum update one) to create a good initrd.

share|improve this answer
    
Are you saying Fedora doesn't support AHCI out of the box? Hell... –  Violet Giraffe Mar 12 '13 at 9:33
    
@VioletGiraffe : I think it does, it would include AHCI in initrd as long as it detects you're using it... So follow Haydn's advice, it's the right one (same as the accepted answer here) –  don_crissti Mar 12 '13 at 10:47
    
Is it normal that with AHCI Fedora doesn't boot at all, though? GRUB isn't even executed. –  Violet Giraffe Mar 12 '13 at 11:21
    
@VioletGiraffe from the thread above it reads it does support it, but only if compiled with, which you can't do as yours doesn't boot when using AHCI. Kindof a catch 22, but the steps above force it to compile with support, so after enabling and switching it'll boot. –  HaydnWVN Mar 12 '13 at 16:51

My first piece of advice is to switch back to a bootable state (ie, IDE or Compatibility mode in the BIOS) and check your kernel for AHCI support; if it is, as I suspect, turned off in the kernel Fedora won't know how to boot and will thus fail.

Once you have a kernel that supports AHCI you should be able to re-enable the BIOS setting and boot your machine from AHCI.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.