Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have a website that is responsible for running a bunch of Crystal Reports and displaying them in the browser. This part works fine, however the website was recently set up on a new server and we're having an issue actually printing the reports.

When we try to print the reports the print dialog shows up, but so does the error "No default printer selected. You may use the control Panel to select a default printer."

Now there are default printers selected on all the computers, no other application seems to have a problem with this. The printers are all network printers and they all print fine. I tried running a report and printing it from the server itself, and it worked fine. It just seems that the desktop machines can't print reports using the Crystal Report Viewer.

Anyone know why the default printer is not being recognized? Or anything that would cause this issue?

share|improve this question

2 Answers 2

I had this issue a while ago and whilst I think it is a bug that causes it (not detecting the network printers as a valid printer).

I resolved it on one machine by installing Bullzip PDF printer, and on another machine, before I heard of Bullzip, I resolved it by manually adding a local HP printer that did not exist from drivers and chose "print to file" as the default option.

share|improve this answer

What version of CR?

I've seen issues where if the person creating the report prints the report to test it, for some stupid reason, CR XI will hold on to that printer as the default and cause the issues that you're seeing. It seems to have cleared up, or gotten better in CR2008. There is a setting (I believe it's on page setup) where you can optimize the report for the screen and that seems to help in earlier versions of CR.

share|improve this answer
    
You're right, that is an issue with creating crystal reports, but it's not the reason the reports are failing to print. We already made sure all the reports are setup properly awhile back. –  Brandon Oct 16 '09 at 1:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.