Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Copied over my Chrome install to new OS. Worked fine. Copied the shortcut from desktop to the “Quick Launch” bar.

At some point, I tried to run Chrome using the shortcut desktop. “Class not registered” error box. Tried the “Quick Launch” shortcut, worked!

Why? Both shortcuts are identical. One was just copied to the “Quick Launch” bar. Why would one shortcut be producing that error and the other one not?

BTW, if I run the shortcut as admin it works.

share|improve this question
Is that stable version of Chrome or some other channel? I remember one dev version had this problem, next update fixed it. – gronostaj Mar 1 '13 at 21:43
Ver. 25.0.1364.97. I do get an update failed in the about so possibly it hasn't updated in a while(not sure why). Obviously just copying over the google folder probably causes problems with the updating. – Archival Mar 1 '13 at 21:56
I think you should make a clean install and restore your profile by copying its directory (C:\Users\YourUserName\AppData\Local\Google\Chrome\User Data\Default) or just sync it using a Google account, it always worked great for me. – gronostaj Mar 1 '13 at 22:01
@gronostaj syncing is not all that easy. I have tried and many extensions do not sync there settings automatically. I'd rather not install chrome for no reason as it seems to work fine except those two issues. I guess I don't have a choice but to try it though. I think I'll just install to a sandbox and copy over the exe and see if that works. – Archival Mar 1 '13 at 22:13
When I copy the working quick launch shortcut to the desktop it works once or twice then goes to back to the error. Either windows or chrome is screwing with something. I'll try and make a script that executes chrome and use a shortcut to the script... which probably will work fine. – Archival Mar 2 '13 at 16:38

1 Answer 1


Start > Run > regsvr32 ExplorerFrame.dll > Ok > Reboot


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.