Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running a basic Ubuntu 12.10 server with LAMP and OpenSSH packages installed in VirtualBox.

The reason I did this is because my school's server breaks connection when I need to FTP my projects for class. I'm studying PHP and want a quick way to test my code locally, then I won't have to FTP every five minutes while developing.

So, I'm stuck at the part of the tutorial where I change the ports/setup forwarding/assign static IP addresses/do_other_things_with_networks_that_I_cant_do, so that the host machine (Windows 7 with Putty) will be able to see the guest and connect.

Thanks for any advice

share|improve this question

closed as not a real question by Canadian Luke, Renan, Windos, Mokubai, Dave M Mar 12 '13 at 12:14

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
where is the server ? I'm guessing its a VM - you shouldn't need to forward ports if its inside your network –  Journeyman Geek Mar 2 '13 at 3:47
    
If the only reason for the setup is the breaking connection, I'd recommend that you double check your FTP client settings. There should be a keep alive setting somewhere that allows you to not disconnect. More often that not it's actually a setting on the client, not the server. But no ports need to be forwarded, once I'm home and can check the exact settings I have I'll post an answer. –  nerdwaller Mar 2 '13 at 4:37
    
I'm using ShiftEdit in Chrome to edit my files and FTP. There's not a "keep alive" option in the Preferences that I can find. I don't know that it's breaking connection, I just know that it randomly (at least once a day) locks me out of the folder window and I can't get back in, sometimes until 24 hours or so later. –  somethingpurehearted Mar 2 '13 at 16:15

1 Answer 1

Easiest: Select SSH package on install of Ubuntu server

When installing Ubuntu from an Ubuntu server image, you can actually just check the ssh-package in the install process. The user and password will be the user and password you selected for your own user during install.

Then just connect to the virtual box server's ip on port 22, with putty. I think this is the fastest solution if you don't like to setup anyting.

You shouldn't need to forward any ports if you just run a virtual box machine on your local host. You can find the IP of your virtual box machine, by entering "ifconfig", in it's terminal window.

If you don't want to reinstall your LAMP

You can install ssh-server by entering this command: sudo apt-get install openssh-server

(This most of the time, enables you to login with the user/password you entered during install. On port 22.)

For more details look here: Ubuntu official openssh server documentation for 12.10

share|improve this answer
    
I tried to use Putty with all the addresses listed in ifconfig, but none of them worked on port 22. It said "Connection timed out". –  somethingpurehearted Mar 2 '13 at 16:10
    
Also try pinging the ip of your server, to see if you can even reach it. If you can't reach it ssh won't work either. –  MarkusDBX Mar 2 '13 at 23:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.