Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I found that WiFi is draining too much battery power on my laptop.

The system has Linux Mint 14 (32 bit) and runs with its default kernel, 3.5.0-17-generic. The driver in use is ath9k and runs on Intel i3 processor.

It takes just 30 minutes to drain a fully charged battery.

By checking iwconfig details, I can tell that Power Management is turned on.

Driver and device details:

@mintbox ~ $ sudo lsmod | grep -i ath
[sudo] password for : 
ath9k 116549 0 
mac80211 461161 1 ath9k
ath9k_common 13783 1 ath9k
ath9k_hw 376155 2 ath9k,ath9k_common
ath 19187 3 ath9k,ath9k_common,ath9k_hw
cfg80211 175375 3 ath9k,mac80211,ath
@mintbox ~ $

@mintbox ~ $ lspci -vvv | grep -A 10 Wireless
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
Subsystem: Foxconn International, Inc. T77H126.00 802.11bgn Wireless Half-size Mini PCIe Card
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 16
Region 0: Memory at e7a00000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: ath9k
Kernel modules: ath9k
@mintbox ~ $

I understand that my laptop will use more power with WiFi, but I am looking for suggestions on tweaks that can help, like putting WiFi in stand by when not in use. I can compromise on network speed to an extent.

share|improve this question
4  
While WIFI does consume power, are you sure its the primary culprit - have you used something like "Powertop" to check its not other activities you do while connected with WIFI which are consuming lots of resources ? –  davidgo Mar 2 '13 at 8:27
    
Try running the laptop with WiFi turned off (oldish machines have a physical switch for that). I'd guess it is just that the battery doesn't hold much charge anymore. –  vonbrand Mar 2 '13 at 23:08
    
@davidgo Yes, I found some unusual cpu usage while looking at powertop output. So this is more like a 'high resource usage' problem when connected to internet. If you post your comment as an answer I will accept that and add more details to it. –  fayadfami Mar 7 '13 at 13:11
    
Done, thank you ! –  davidgo Mar 7 '13 at 18:58

1 Answer 1

While WIFI does consume power, are you sure its the primary culprit - have you used something like "Powertop" to check its not other activities you do while connected with WIFI which are consuming lots of resources ?

share|improve this answer
    
Though I was thinking wifi to be the reason, this incident has proved again how important it is to properly diagnose an issue. (a). Powertop output showed me that some drivers not in use were loaded and using cpu. Disabling them using blacklist.conf didn't work. This is the proper way to do it. wiki.debian.org/KernelModuleBlacklisting –  fayadfami Mar 9 '13 at 5:16
    
(b). Tunables option in powertop when toggle changed doesn't save its output and change is not reflected after a reboot. If I can get those changes saved it will give more results. –  fayadfami Mar 9 '13 at 5:18
    
(c). Module blacklisting doesn't work all the time. The reason I find is, the driver in context may have dependent modules and when they are loaded it can bring up the driver. So the question here is, How to find and list the dependent modules of a module. –  fayadfami Mar 9 '13 at 5:31
    
The answer to my question (c) is ldd command. It can list dynamically loaded modules. It is also useful in getting details of binaries. ibm.com/developerworks/library/l-lpic1-v3-102-3 –  fayadfami Mar 11 '13 at 5:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.