Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was using Windows 8 the other day and noticed that there is now a second cursor image (arrow) at the top left of my screen. It doesn't move, it doesn't do anything really, except sometimes go busy if the window below it is loading something.

My regular mouse cursor works as it should and moves when I move my mouse. I checked device manager, but it doesn't think that there's another mouse attached to the computer. It stayed after I rebooted my machine.

What should I do? Should I leave it there and see if it grows? Feed it cheese? Perhaps wiggle the other mouse and see if I can scare it away?

share|improve this question
It's spring, they are multiplying =) – Desmond Hume Mar 2 '13 at 14:04
But srsly, have you recently changed hardware/software configuration of your computer? – Desmond Hume Mar 2 '13 at 14:09
I recently added a new display driver, but i've already uninstalled that :/ – Jason Mar 2 '13 at 14:15
Are there any "unknown devices" in the Device Manager? Does the extra mouse pointer goes away when you restart your PC with your mouse unplugged? – Desmond Hume Mar 2 '13 at 14:22
Does it show up in safe mode? How about regular mode as a different user? – Ƭᴇcʜιᴇ007 Mar 2 '13 at 16:02

2 Answers 2

I was making changes on Windows screen resolution option and i noticed that i had more than 1 screen activated (extend desktop). I enabled only one, and after that the left screen mouse clone disappeared.

share|improve this answer

I noticed the same issue, with my laptop connected to 2 monitors via a docking station. Turns out - I booted the laptop when it was docked and my multiple monitor setting was setup to be '3' displays, the 3rd being the laptop display - which was never turned on since I booted when I was docked. Once I figured this out, I just moved one of my windows to the 'invisible 3rd display' and then back to one of the 2 screens, and the mouse on the top left was gone.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.