Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Basically, whenever I turn on my computer, it gets to the Starting Windows phase and just stays there. The startup animation still plays, yet it gets nowhere.

  • I have tried booting into safe mode, however it gets stuck at loading CLASSPNP.SYS. It then freezes there and doesn't continue booting.

  • I have tried booting into recovery mode from the hard drive, and it freezes after displaying the background image. I have tried booting from a recovery CD, which works, and I was able to use system restore. However, using system restore did not fix it, and it still is stuck at the Starting Windows screen.

  • I have tried booting a Windows CD (Windows 8 Retail Installer) to see if I could upgrade it to fix this issue, however that froze at a blank screen after it got past the boot logo.

  • I have tried changing around the BIOS settings (including resetting), to no avail.

  • I have tried re-plugging the internal PSU cables (this is a custom-built desktop), yet this has changed nothing.

  • I can boot into a loopback Ubuntu install on the same drive, which works fine, other than the fact that it has issues with some of the USB ports and the network card.

  • This system has worked fine for the past few months, completely stable, and nothing in the configuration has changed before this error started happening.

  • Startup Repair on the Windows recovery CD doesn't find any issues.

  • Unplugging my secondary hard drive or swapping around memory doesn't change anything.

  • The hard drive itself is fine, it hasn't shown any signs of failure and once again, boots my other OS fine.

If anyone could help with this, that would be great. I can't seem to find any possible solution to this.

If it makes any difference, my system specs are as follows:

  • AMD FX-8320
  • Gigabyte GA-970A-D3
  • 4GB of DDR3
  • Radeon HD 6870
  • 550w PSU

I'd like to not have to reinstall Windows, for I have more than a terabyte of data that I would have to back up if that becomes the only option.

EDIT: I have since tried the following:

  • Tried the solution involving restoring files from RegBackup, which changed nothing.

  • Tried testing everything with Hiren's boot CD, everything comes back as fine.

  • Tried disabling everything unnecessary in the BIOS and unplugging everything unneeded, it still hangs.

  • Tried swapping out every possible combination of RAM, it still has the same result. The RAM is not at fault it seems

  • Tried every GPU I own (which is many!) and it still hangs at the exact same place.

  • Tried minimizing the power consumption as much as possible, even using an old PCI graphics card. It still hangs at the same place in the same way, signifying that it's not the PSU at fault.

  • Tried resetting the BIOS again, still nothing.

  • Tried every possible combination of BIOS options, even downclocking everything, it still hangs in the same spot.

  • Tried upgrading the BIOS from version FB to FD, which changed nothing.

Based on this, I would conclude the motherboard to be at fault. Are there any other possibilities? I don't want to spend $150 for a new motherboard.

EDIT 2: This is what it gets stuck at when I try to boot into safe mode:

enter image description here

Note the slight graphical corruption at the top of the screen. No matter how I set up the system, this seems to be there. In addition, either it has stopped booting into safe mode now, or it takes upwards of 2+ hours, and I haven't left it running for that long.

share|improve this question
What's the longest you let it sit trying to load normally? Is there ANY HDD activity during this time? Also, when going into safe mode, the last thing Windows lists (CLASSPNP.SYS in this case) is the last thing it successfully loaded, so it's hanging on the 'next' thing (that it doesn't display). You say you drives are OK, how did you establish this? Did you run and disk checks to check the file system itself? Are there any "Found.000' type folders in the root of your drive? – Ƭᴇcʜιᴇ007 Mar 2 '13 at 20:50
To me it sounds like you're either not letting it finish doing whatever it's doing at boot (I'd wait upto ~20 minutes for things like finalizing changes you made before your last reboot), or you have disk/file system corruption (probably in your registry). – Ƭᴇcʜιᴇ007 Mar 2 '13 at 20:52
Can't believe so many people think it's a problem with ClassPNP... to make it's just a red herring. – Mehrdad Mar 12 '13 at 16:09
I'll note what's written in the picture: Loaded: \Windows\system32\DRIVERS\CLASSPNP.sys. ClassPnP was LOADED, and the problem is in the NEXT driver, which stucks. So, the half of the answers are NOT TRUE. – Jet Mar 23 '13 at 11:13
You guys are just making wild assumptions. One guy stated that his motherboard broke his CPU and that's what caused it. Yeah. Your computer wouldn't even load with a non working processor. Like I said, unhook any newly attached hard drives. – dev Apr 21 '14 at 8:51

14 Answers 14

To detect the source of the problem and to avoid re-installing Windows on faulty hardware, you could test your hardware for potential malfunctions.

For this purpose, download and burn a recovery/diagnostics CD. I personally prefer Hiren's BootCD Here is the download page.

Boot from that CD and try running basic tests, like Memtest86+, which is for RAM, and MHDD, which is for hard drives and can detect bad sectors on your HDD. Notice the tool named Remove Non Present Drivers. Do some preparatory research on the tool you are going to use, be as careful as possible.

Hiren's BootCD offers a number of anti-virus and recovery tools as well. It also includes a Mini Windows XP that you could use to browse files, for example, to see whether renaming a questionable driver so that your Windows doesn't load it on next boot makes any difference, and backup files to a USB stick.

Before getting into troubleshooting, disconnect as many devices as you can. If your motherboard has built-in graphics support, unplug your graphics card and switch your display to the motherboard's video output instead.

Hope you find it helpful.

share|improve this answer
It's helpful thing. But it won't fix the problem until you know where is the problem. – Jet Mar 23 '13 at 11:16

I noticed eubakup.sys and EUBKMON.SYS which aren't "standard" Windows drivers. You may try booting into your system with a Windows PE disk and renaming those files so the drivers don't load on next boot and see where you get.

The only time I've really experienced this issue is when the jumpers on my IDE drives (I put Windows 7 on an old P4 as an experiment) were set to cable select. If your USB and network card issues on the Ubuntu live CD are intermittent in nature I'd say your motherboard is kicking the bucket.

share|improve this answer
These dlls belong to EASEUS Todo Backup, so are legitimate. – harrymc Mar 13 '13 at 14:41
No,no,no.It's not an universal method to fix the problem. You're lucky if in your case it was problem of non-standart drivers. But any driver which has problems, and which is loaded AFTER ClassPnP.sys, can cause this problem. And often that driver is system's OWN driver. So you can't just delete it. You must reconfigure it, or change back its settings. – Jet Mar 23 '13 at 11:01
Absolutely agree that care/doing your homework is needed if you do this and it's a troubleshooting step, or a way to get a bootable system quickly. In the above case I'd say the EASEUS software probably needed to be updated or reinstalled. – LawrenceC Mar 23 '13 at 13:52

I'll tell you now, it's not hardware. Forget the motherboard being at fault, it almost certainly isn't. Other OS's work fine, that tells you the hardware is ok.

This is undoubtedly a corrupt install of windows caused by a few bad blocks. This can be windows own fault, not the hardware itself.

What you really need to do is get into the recovery console of windows 7 again, open the command prompt, and run 'chkdsk C: /r' (the drive letter of C: may have changed as you're booting outside of windows, but it should be ok as recovery console usually uses X: as its default root directory. This can take anywhere from 15 minutes to 4 hours or more to run depending on the size and speed of the hard drive (empty blocks will also be checked.)

You can also try SFC /SCANNOW but I don't know how this works in the recovery console (I've only ever needed it in a desktop environment). It checks the integrity of windows system files and requests to replace as necessary.

This will check your partition extensively. See

Source: 4.5 years desktop and server support experience covering 70 companies running anything from windows 98 to windows 7.

share|improve this answer
How do you explain that the Windows 8 upgrade fails very early in the boot from dvd? – harrymc Mar 12 '13 at 16:04
@harrymc Windows 8 will scan for previous installations of windows. It may be doing this at the time of hanging (getting stuck on bad blocks on the HDD that'll tell it where the install location is or checking that location to verify), but having not played with windows 8, I couldn't tell you when it checks for previous versions so I don't know if that's what it is doing or not. – Simkill Mar 12 '13 at 16:13
Your conclusion is therefore a bad disk, same as mine. But how is that not hardware? – harrymc Mar 12 '13 at 16:30
I don't think you can pass this assumption as fact. I've seen Windows installations hang during boot on lots of issues other than bad blocks (which tend to be hardware problems by the way), ranging from wonky USB devices, dusty PCI cards and bent processor pins. The possibilities really are endless. – oKtosiTe Mar 12 '13 at 16:33
@harrymc Bad sectors/bad data in those sectors are not always a sign of hardware fault. It could easily be windows failing to complete a write operation when suffering power loss for instance. – Simkill Mar 12 '13 at 16:37

If it's really bad blocks, buy a copy of Spinrite. Run it at level 4, it will thoroughly test all sectors at the disk level (it does not care about OS), and if it finds a bad one it will keep rereading the sector with minute head adjustments, in an attempt to statistically recover the data in that sector - often with success.

The best of all: it comes with a money back guarantee and their service is great.

share|improve this answer

You don't mention exactly what tests you have performed on the drive, but based on your symptoms, this could very well be caused by bad sectors on your drive. Especially if you didn't mess around with hardware or drivers just before the problem occured.

Try running a disk test that reads the whole disk, byte by byte. Various forms of 'quick tests' might not hit the area with the bad sectors. A SMART test might not even report any problems.

Using a test tool that reports or graphs the results in a way that makes it easy to spot areas taking unreasonably long to be read is a must. Not all tools do this.

share|improve this answer

It can be consequence of bad drivers, or bad/half updates.
Sometimes it can happen if you plug any device while system is booting (in that case try to unplug all devices except important ones, and restart). It can cause if you/any program changes some registry settings.
And also there's an interesting thing: most of all it happens if you haven't activated your OS.

Try recovering registry (not files) by following these steps. It always solves such problems.
All you need is to gain access to your hard drives. Use any bootable-disk (such as LiveCD , Hiren BootDisk, or even Windows installation disk or WinRE) for it. After you can access your hard drives, do these steps:

  1. Go to this folder: C:\Windows\System32\Config
  2. Create some folder and COPY these files (for backup):
  3. Copy files SOFTWAREand SYSTEM from directory C:\Windows\System32\Config\RegBack to C:\Windows\System32\Config and Restart your PC.

Now it must work fine.
If the problem still exists, then do 1st and 3rd steps, but copy these files: DEFAULT,SECURITY,SAM. Now all your registry restored.

You can also check your drivers and update them. Or download DriverPack Solutions and let him do it all.

NOTE 1: This is an universal solution, and can be used to fix a lot of problems - from driver errors to virus infections.
NOTE 2: It works in Windows from XP to 8, if registry backup (not file backup!) is enabled (and it's enabled by default)

Good luck!

(P.S. ClassPnP has NO MATTER here. It was LOADED, and the problem is in the NEXT driver which is being loaded. To find what caused the problem, use any tool (I think Sysinternals had a tool for it) to get driver load order list. And after that, find the driver which was loaded AFTER ClasssPnP.sys. The problem is there...)

share|improve this answer
The instuctions here closely match this MSKB article about recovering from a corrupted registry in XP. Cannot confirm they'll work with 7 (not done it myself on 7, have done so with mixed successes on XP, the procedure definately works) but if the backups are there it'll 'reset' the registry. – HaydnWVN Mar 12 '13 at 16:41
Surely, this works for Win 7. Yes, this will reset the registry to the last backup date, but sometimes it's the only way to recover Windows (after such errors, driver errors and virus infections). – Jet Mar 14 '13 at 13:04
Have you done it on Windows 7? – HaydnWVN Mar 19 '13 at 13:37
@HaydnWVN Yes I've tried. It works fine on Windows 7. – Jet Mar 19 '13 at 14:53
Good to hear, thanks! – HaydnWVN Mar 21 '13 at 15:27

I faced a similar problem a while back. For me the problem was that the system drive was having some inconsistencies, which required chkdsk to be run on it. But windows could not run chkdsk, as chkdsk required to lock system drive. You cannot run chkdsk after OS has been loaded, causing the deadlock.

To fix the problem, I had to :

  1. Boot from Windows Vista/Windows 7 installation DVD
  2. Select language and continue, choose option to Repair your computer.
  3. After scanning OS it will show you options, choose Command Prompt
  4. Type chkdsk /f C: (whichever is your system drive)
  5. If it shows Chkdsk cannot run because the volume is in use by another process. Try this chkdsk /x C:
  6. Reboot normally and check.
share|improve this answer

You used Hirenboot only to test or what there's very good tool that will probably help you with your problem, the problem is in hard disk and the bad sector not releasing the file crucial to boot windows chkdsk /r might help but , i highly suggest to run the HDAT tool that's on hirenboot and leave it to scan with first option after the scan finishes if you see B .....B .....B than it is the disk 100% but you have a chance to login to windows after that, . And usually the problem is always with c(hidden recovery partition) but sometimes it is really the end for the disk, if HDAT says after let's say hour of testing media not present than get a new disk and save your important disk data with testdisk(it's free and it is on hiren you can easily find how to use it on internet.

share|improve this answer

I had a similar problem. Went to all the sites trying to solve the problem. One day I decided to reset the BIOS. Did it and the computer started working.

share|improve this answer

I had this problem after hooking up a new SSD. All I needed to do was unhook it, and then Windows started up just fine.

share|improve this answer
this doesn't sound like much of a solution – Sickest Apr 21 '14 at 9:24

I happened to see this article just now and saw that the article is quite old so assume that the owner of the post must have rebuilt his machine by now. Still I'd like to add an answer of my own for anyone else that comes across this.

I think @ultrasawblade above was on to something when he spotted eubakup.sys and EUBKMON.SYS in the screenshot and correctly identified these as being non-standard" Windows drivers. When I see the screenshot above I can see how those drivers get loaded just a bit before Windows doesn't continue any further.

If I ever use backup software, I notice how the driver for the backup software gets referenced in the stack trace in each and every read and write operation. I would hazard a guess that in this person's situation that that would also be the case and that the driver would start looking at any drivers that get loaded thereafter. For some reason CLASSPNP would pass fine and for another reason the driver after that would be prevented from loading. That should allow the machine to boot up again.

To resolve this, one could try running Sysinternal's Autoruns tool in offline mode. I've used Autoruns though not in offline mode so will try my best to explain this. One would need to boot into the system with a Windows PE disk and then run Autoruns (File -> Analyze Offline) and then point it to the Windows folder. One can then hide any Microsoft entries to focus on and disable those drivers above.

share|improve this answer

You can extract the CLASSPNP.SYS file from Windows DVD using procedure described in this article on your ubuntu:

Then rename old file and put the new one in its place. Then, try booting into safe mode.

Another thing:
Try using the hard drive in ATA mode instead of AHCI mode. This setting can be changed in BIOS and should carry a label like SATA mode or something.

share|improve this answer
This is not ClassPnP's problem. So copying ClassPnP will NOT help you. – Jet Mar 23 '13 at 11:04

I had the same motherboard and CPU. My Windows was stuck on the Windows logo – and when I run it on safe mode it got stuck on classpno.sys.

I bought a new GA 990XA UD3 motherboard but the problem persisted. I used the same CPU on my friend's PC and I saw that the same problem appeared on this PC too. I changed my FX8320 under warranty and now it works perfect.. try to use some other CPU on your motherboard.

But be careful because I think that the problem with CPU started from the GA 970A D3.

share|improve this answer

Try booting into safemode in command prompt. From there do the following:

1: type in, "cd C:\Windows\System32\Drivers" press enter 2: type in "rename classpnp.sys classpnp.sys.old" press enter

Restart the computer. If this does not work or you cannot boot to safe mode in command prompt you will have to reinstall the OS. If an OS install does not work the problem is hardware. Try another hard drive. If the Hard drive does not work it is most likely something on the MoBo

share|improve this answer
Try to add more explanations to your answers on why you came to each diagnosis. – HaydnWVN Mar 12 '13 at 16:43
1) It's not a problem of ClassPnP. 2) As I remember, Safe Mode is not working in this case. 3) If you rename ClassPnP, it's hardly possible that you can boot to your OS. It's a fatal driver. So, your answer is incorrect =) – Jet Mar 23 '13 at 11:09

You must log in to answer this question.

protected by Community Apr 21 '14 at 9:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .