Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My USB external hard drive with NTFS format works just fine on Ubuntu Linux, but when I boot the same machine as Windows Vista, it no longer recognizes the drive (it used to work fine on Windows). Another Windows machine also doesn't recognize it. It shows the drive letter in Explorer but can do nothing else. I can't see the drive through cygwin.

I've copied my data off the questionable drive, so the data is reasonably safe now, but is there any way to fix the drive without reformatting it? As I said, it's perfectly serviceable on Ubuntu, but I need the Windows access.

share|improve this question
    
Just an update on this one...I got the drive running on my old desktop with a SATA-IDE converter and some spare power cables, but I couldn't get DBAN to run against this drive when I tried to boot with the DBAN CD. I didn't have the know-how to debug that situation, so I simply went onto the desktop through Windows and used the Computer Management tool and removed the partition from the drive, then formatted a new clean partition. Now the drive is back in the external casing and it's recognized by my regular Windows box. Now it's good to go. –  jgumpert Nov 29 '09 at 2:04

3 Answers 3

The times I have seen this it was a disk fault, not necessarily hardware. On the machine that assigns it a drive letter, one cheap and easy technique is to just run chkdsk /f on it.

share|improve this answer
    
Tried this approach and was able to run 'chkdsk e: /f /r'. It seemed to find some corrupt attribute records, list entries, and file record segments and fix them. But the drive still won't work on Windows. I've ordered a SATA to IDE converter so I can try running the drive from my dusty old desktop and see if Tim's suggestions work better. Thanks for the help! –  jgumpert Oct 18 '09 at 17:56

When I've had this happen in the past, it has always been because the hard drive has some sort of physical sector error, etc, so I'm not sure there would be any way to fix it without reformatting. The way I've dealt with it in the past is:

  1. Remove the hard drive from the USB casing.
  2. Connect the drive directly to the SATA or IDE interface on my PC motherboard, depending on what type of drive it is.
  3. Use a utility such as SpinRite to repair the drive's errors.

A free alternative that has also worked in the event I don't need to recover data off of the drive is to use Darik's Boot and Nuke (DBAN) to wipe the drive completely, which will force the drives internal SMART logic to "map out" any problem sectors so that the drive will be usable again. You can just use the "blank drive with zeros" option in DBAN so that you don't have to wait eons for the "secure erase" methods to finish. This will only work if the drive isn't too badly damaged, though. If DBAN fails to blank the drive, it's probably time to buy a new drive.

share|improve this answer

yes "chkdsk [drive:] /F" worked for me. even you can use "/c" switch to make it faster but might end up with a few skipped errors.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.