Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I currently have Fedora 18, ATI Radeon HD 7730M and an i7 Processor on my laptop, it going crazy making lots of noise, how can i know what is making noise,

if it is the ATI card, how can i unload it and use the default intel one?

if it is the CPU fan, what can i do?

please, get me some help on this?

edit: got this info from sensors

radeon-pci-0100
Adapter: PCI adapter
temp1:       +511.0°C  

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +48.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +44.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +47.0°C  (high = +87.0°C, crit = +105.0°C)
Core 2:         +40.0°C  (high = +87.0°C, crit = +105.0°C)
Core 3:         +43.0°C  (high = +87.0°C, crit = +105.0°C)

How can i unload the radeon because i don't need graphic?

share|improve this question
    
You should read Eats, Shoots & Leaves –  Dour High Arch Mar 3 '13 at 0:28
add comment

3 Answers

Your laptop actually only has a single fan that cools both the CPU and the Gfx-card:

http://auctions.c.yimg.jp/img375.auctions.yahoo.co.jp/users/2/2/4/6/junji_eighth-img600x450-1354879118kwrbur16369.jpg

So, if either the Gfx card or the CPU gets hot, it will spin up the fan and create the noise you are hearing (unless of course it is an almost broken HD or a CD in the drive).

As far as fixing the problem goes: If Fedora is missing some support for the specific power management module used in your laptop, you might be out of luck. Maybe try looking through the package manager to see if there is some power-management or ACPI package you are missing.

As far as unloading your ATI card goes, try going into the BIOS settings and look for a setting that chooses which Gfx card to initialize first. Pick the on-board one there.

share|improve this answer
    
at least to rule out the Graphic Card, how can i unload it and use the dafault one? –  Noor Mar 3 '13 at 0:08
    
I haven't tried it in Fedora, but Ubuntu will default to using only the gfx card that you choose as the primary one in the bios –  Markus A. Mar 3 '13 at 0:10
    
Check out this: ask.fedoraproject.org/question/7176/… Maybe they screwed something up in Fedora 18. You could try Fedora 17 and see if it's better? –  Markus A. Mar 3 '13 at 0:12
add comment

Give fglrx a chance. Check wheter cpufreq util is working well. If it isn't you can find documentation on man pages and at wikis. Poorly designed laptops ( Like HP Compaqs with AMD processors ) may cause such problems also check your fan it may be dirty.

Edit: To unload a module in kernel use :

# rmmod module_name
share|improve this answer
    
The laptop, I just bough it yesterday, its a DEll Inspiron 7520, i've been fighting to install ATI with no sucess –  Noor Mar 2 '13 at 23:57
    
If it doesn't matters to you. You can try another distro that supports proprietary software/drivers in it like openSUSE. –  6ng4n Mar 3 '13 at 0:11
add comment

I had a similar issue, it turned out it was the ATI graphics card overheating. First you must enable fixed mode for the graphics card in the BIOS. Then in Fedora, as root run:

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

This will solve it temporarily, in order to make the changes stick simply add the command to /etc/rc.d/rc.local (create it and chmod+x if it doesn't exist).

To check that the command was successful, run:

cat /sys/kernel/debug/vgaswitcheroo/switch

Your output should look something like:

0:IGD:+:Pwr:0000:00:02.0

1:DIS: :Off:0000:01:00.0

The OFF next to DIS indicates that the discrete card (the ATI card) is powered down.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.