Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

First, a bit of background:

Microsoft brags about how the new Windows 8 Storage Spaces support any interface (including USB) for attaching drives to add to a Storage Pool: under "What do I need to create a storage space?"

Western Digital proudly announced that their drives "fully support the [...] feature":

4th paragraph of

Yet, my 4 new 2TB WD My Passport USB drives are not recognized by the Storage Spaces manager, even though they show up and work flawlessly in the usual Disk Management. A quick call to WD support confirms: These drives will not work with Storage Spaces. So, I will just have to return them.

Now my question:

I'm trying to find out which external USB drives do work with Storage Spaces, but I can't for the life of me find anything on Google. Have any of you had any success with any particular brand or drive? Or can anyone rule out any drives or brand (WD support told me that only their internal drives are supported)?

Addition: The WD-disks WORK if I install Windows 8 inside VMware Player?!?!? WHY?

share|improve this question
@Ramhound That's what I thought... But I don't seem to be the only one:… They are doing some really strange things with these drives anyways. It installs some WD SES Device(?) and tries to provide all sorts of other funtionality... I wish they just built a hard disk without trying to be clever... – Markus A. Mar 3 '13 at 3:03

Looks like this case doesn't come up very often...

I have no new data on my original question, but let me at least share the way I dealt with the issue, to make this question at least somewhat useful:

  1. Install VMware Player (performs much better for this purpose than VirtualBox - I tried both)
  2. Create a new virtual machine and install a minimal version of the latest Debian Linux release on it (you will need the packages mdadm and samba; also helpful is openssh-server)
  3. Pass the desired physical disks to the virtual machine (remove Windows-accessible partitions first)
  4. Set up a RAID array across the disks in Linux
  5. Format the array as ext3 and set it to mount on boot
  6. Share the mounted array using Samba
  7. Mount the share in Windows 8

This method has a couple of advantages over using Window 8 Storage Spaces:

  1. It works! With ANY disks! Internal, external, USB, eSATA, network attached, ... anything!
  2. Performance should be much higher (Windows 8 Parity Redundancy is supposedly very slow)
  3. It gives you more storage space: Windows 8's Parity Mode will always have 50% data-overhead, independent of how many disk you run. Whereas Linux RAID 5's (RAID 6's) overhead is limited to the space of one (two) disk. If you have ten 2TB disks, for example, Windows 8 will give you only 13.3TB, whereas Linux RAID 5 will give you 18TB and RAID 6 will give you 16TB.
  4. You can choose RAID 6, which will tolerate failure of two disks (not available in Storage Spaces)
  5. The virtual machine can but doesn't have to run on the same machine

It also has a couple of disadvantages, though:

  1. It's not as easy/pretty to manage as Windows Storage Spaces
  2. If the connected drives are different size, the system is limited to the size of the smallest drive
  3. It requires loading the virtual machine to be able to access the drives, increasing boot time
  4. Using a Samba share to record Live TV to in Windows Media Center is hard/impossible
  5. It uses up some system memory to run Linux

Hope this helps...

share|improve this answer

Backup those 4 WD external disks. Delete each volume on the 4 disks in Windows Disk Management. Now open the Storage Spaces control panel. You should be able to use the disks to create pools and spaces.

share|improve this answer
I tried... I deleted the partition, I cleaned the disks with diskpart, I reinitialized them, tried MBR or GPT partitioning, with and without partitions on the disk. I even played with diskpart's setid. These disks simply don't work due to the way the USB controller lists them on the bus... And WD support confirms this. – Markus A. Mar 14 '13 at 14:58

Here are the ones I've found so far:

share|improve this answer

I was having the same problem with 4 Segate expansion disks. If I used a 4 port PCI USB card it would not recognize them even though they would work as stand alone drives. However after a little more work I found that Storage spaces would see the drives if i used the motherboard's native USB ports and a Sharkk 3.0 hub. The drawback here is speed. The motherboard I have only supports USB 2.0 speeds and I was hoping to use the full capability of USB 3.0

share|improve this answer

A usb that works with Storage Spaces on Windows 8.1.
In a JBOD configuration, 'WD My Book Duo Enclosures' definitely work with Storage Spaces on Windows 8.1.

share|improve this answer
In a JBOD configuration, that is. – thetaphail Jul 7 '15 at 6:25

Remove the Windows device stage for the WD drive and stop Windows from automatically installing driver for it. It works without the driver installation.

share|improve this answer
let me digest this, you said it works without a driver? how could be possible? – Francisco Tapia Sep 16 '15 at 14:32
Remove the WD drive in Devices and Printers, then disconnect the Internet and reconnect the drive. It works and make sure not automatically find driver from the Internet. – whatisallthis Sep 19 '15 at 13:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.