Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just discovered an incredibly annoying "feature" of Windows 7 tonight. If you click on your optical drive in Explorer, and there is no disc in the drive, Windows 7 is kind enough to open the tray for you. I'm finding it hard to contain my rage over this idiotic design decision. WTF?

According to this post, this behavior was apparently introduced in Vista. The author posted a workaround, but I don't want a workaround. I want it to stop doing this. Like he, I have a case with a door that covers the drive bays. If it's closed, and I accidentally click on that optical drive, it knocks on that door 10 or 12 times before giving up.

Can this behavior be turned off in Windows 7?

share|improve this question
    
Why do you double click on the drive if there's nothing in it? :) –  alex Oct 16 '09 at 5:18
    
Ha I never noticed that before in Vista. @alex I always assumed that you can browse the optical drive to drag-drop files for burning, if it's a DVD writer that is, even without media. I'm very confused as to why it doesn't support this anymore, did I just dream that? Strange indeed. –  invert Oct 16 '09 at 6:24
3  
@alex: It doesn't even require a double click. A single click will do when you click on the drive in the folder tree. –  raven Oct 16 '09 at 12:26
    
On my PC it only works with a double click. I tried it this morning, after reading your question; a single click does nothing. –  alex Oct 16 '09 at 13:09
    
This is incredibly annoying. I totally agree about this being a completely stupid design decision. +1 for the question/answer. Unfortunately I did use the built-in Windows burning functionality, and now I can't. –  Rich Aug 12 '10 at 2:04
show 1 more comment

2 Answers

up vote 6 down vote accepted

You could try disabling the Windows built-in burn functionality. Apparently, this will also stop the auto-eject feature. You can read more about it here.

share|improve this answer
    
His statement, "Only DVD RW drive will auto eject and open when clicked on its icon. DVD-ROM drive won’t has the effect." is wrong. I just tried it on a computer here at work that has a DVD-ROM drive (not a burner) and it popped right open. –  raven Oct 16 '09 at 12:30
    
However, his instructions for removing the CD burning features did the trick. –  raven Oct 16 '09 at 12:54
    
Glad to know it worked for you! –  alex Oct 16 '09 at 13:08
1  
Thanks, that worked for me on Windows 7 (but how stupid that you have to disable useful functionality to get rid of this ridiculous annoyance). –  EMP Apr 1 '12 at 0:55
1  
your link is dead, here's an alternative and a superuser post about it –  BornToCode Nov 16 '13 at 20:22
show 1 more comment

My solution is to disable CD/DVD ROM from the Device Manager. But you have to re-enable when you're going to use it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.