Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have one PC running Windows XP Professional on a workgroup and another PC running Windows 7 Professional. I want the XP machine to be in time sync with the Windows 7 PC. I have disabled the firewall on connections between the two PCs.

On the Windows 7 PC I started the Windows Time service.

On the XP machine I ran the command NET TIME\W7machine and got error:

System error 5 has occurred.

Access is denied.

Can anyone help?

UPDATE I followed these steps: Click Start, click Run, type regedit, and then click OK. Locate and then click the following registry entry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config\ In the right pane, right-click AnnounceFlags, and then click Modify. In the Edit DWORD Value dialog box, under Value data, type 5, and then click OK. Enable NTPServer. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpServer\ In the right pane, right-click Enabled, and then click Modify. In the Edit DWORD Value dialog box, type 1 under Value data, and then click OK. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\VMICTimeProvider\ In the right pane, right-click Enabled, and then click Modify

from http://windows7forums.com/tweaks-guides-howto/43921-windows-7-authoritative-time-server.html

and then on Windows 7 PC, instead of using NET TIME command I instead set the internet time server in Date/Time settings on XP PC to hostname of Windows 7 machine. It is possible I didn't need the registry tweaks, but I did that before thinking about the Date/Time section on XP.

share|improve this question
3  
Why don't you just let them both synchronize with "time.Windows.com" as is their default setting? That way they will not only show the same time, but also the correct time. –  Austin ''Danger'' Powers Mar 3 '13 at 14:59
    
Agreed with Dan is there a reason not to have them sync with a network time source? –  Brad Patton Mar 3 '13 at 15:07
    
That is how it was set when I had the time difference. Possibly I just needed to hit the update now button. –  user619818 Mar 3 '13 at 15:30
1  
The steps are: 1. Install and configure an NTP server on the Windows 7 PC. 2. Tell the Windows XP PC in its time settings to sync with the installed server. –  Desmond Hume Mar 3 '13 at 16:56

1 Answer 1

AnnounceFlags set to 5 should never be combined with syncing your time server itself with another internet time server!

If you set the AnnounceFlags to 5 and restart the Windows Time service the stratum of your PC will be 1. You can verify this with the command w32tm /query /status.

Because 1 is the primary value, all other PCs will be able to sync with this machine, and get their own stratum level of 2. (All seems fine till now.)

But Windows has a problem here: If you also set your time server PC to sync its own clock periodically with another internet NTP server the stratum level of your PC will change to one higher than the NTP server it just synced with (eg. if the NTP server was stratum 1 you will now become stratum 2).

You can verify this by manually triggering an update and the issuing w32tm /query /status command again. If you now try to sync from the other PC again with the PC you set as time server it will notice the stratum is the same or lower as its own and will give an error when you try to sync.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.