Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell Inspirion 5520 that has Intel(R) Centrino(R) Wireless-N 2230 built in.

Also I have a TP link TL-WR740N wireless router.

I have an 80Mbps/25MBps internet connection.

My Speedtest result with no router:

enter image description here

When I connect all these via an Ethernet cable, I get the maximum even through the router:

enter image description here

But when I try to do the same with WiFi I get 30/20 Maximum speed, and I'm sitting next to router!

I have this configuration:

router:
- Channel: auto
- Mode: 11n only
- Channel width: 40Mhz
- Max Tx rate: 150Mbps
- Enabled Wireless Router Radio
- Enabled SSID Broadcast
- Security: WPA- AES
- Beacon Interval : 100
- RTS Threshold: 2346
- Fragmentation Threshold: 2346
- DTIM Interval: 1
- Enabled WMM
- Enabled Short GI

Intel(R) Centrino(R) Wireless-N 2230:
- 802.11n Channel width for band 2.4 : Auto
- 802.11n Mode: enabled
- Ad Hoc Channel 802.11b/g: 1
- Ad Hoc QoS Mode: WMM enabled
- Bluetooth(R) AMP: Enabled
- Fat Channel Intolerant: Disabled
- Mixed Mode Protection: CTS-to-self Enabled - Roaming Aggressiveness: 3. Medium - Transit power: 5. Highest - Wireless Mode: 802.11b/g

I do get the fact that speed through wireless is slower than with wire, but losing 50Mbps is a bit too much!

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted
  1. Disable Bluetooth on the Centrino 2230.
  2. And also set Bluetooth(R) AMP: Disabled.
share|improve this answer
    
thanks! this made it work! I would have not guessed that the bluetooth would interfere this much! speedtest.net/result/2558140781.png –  NaGeL182 Mar 7 '13 at 22:29
    
how comes enabling/disabling bluetooth effects wifi transfer that much? –  Yevgeniy M. Aug 2 '13 at 21:09
    
I thnink it's because both Bluetooth and wifi operate in the range of 2400–2483.5 MHz. So this causes interference with each other. Your microwave could also be interfering(if poorly shielded) ... see: Electromagnetic_interference_at_2.4_GHz –  Robb Aug 29 '13 at 22:36
add comment

Having G devices on your network can slow down the speed for all devices. Encryption, distance and interface can also limit your speed.

SmallNetBuilder has a couple of good articles on steps you can try:

share|improve this answer
    
I'm the only one on the router currently, and i read those articles, sadly didn't help. –  NaGeL182 Mar 3 '13 at 21:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.