Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a self-installed Lenovo T500 laptop. Yesterday, I tried plugging in my LG monitor and changed two things: - I extended the desktop to it so that I could see two documents side by side. - I selected the 3rd monitor in the combo box located between the picture of the screen and the resolution slider, which funnily showed no name for the display driver (so the caption was something like "Plug and Play Monitor with")

As soon as I hit 'Apply', both screens started displaying garbage, and this persists after a reboot. The screens display colors, but the picture seems chopped up in small rows that are offset so that there is no way to recognize anything.

I started XP in VGA mode, which works fine, but in the display settings dialog, I don't have the same choices as I had in normal mode, so I can't undo what I did: there's no combo box to select the display, and there's no option to extend the desktop.

How can I change this back?

I also tried disabling both Intel graphics adapters, uninstall all monitors from the hardware manager and update to the latest drivers for the graphics card, without success, the garbage persists when booting without VGA mode.

  • Windows XP SP3
  • German system (I may not always know what things are called in an English system).
  • Laptop: Lenovo T500 type 2243-4MG
  • Mobile Intel(R) 4 Series Express Chipset Family

Let me know if some important info is missing.

Thanks,

Carl

share|improve this question
    
Have you also tried to uninstall the display drivers? Just to get it back to some sort of factory setting and erasing all current settings? –  Ivo Flipse Oct 16 '09 at 8:19

2 Answers 2

up vote 1 down vote accepted

I finally fixed the problem by tweaking the registry directly. As always, be very careful when modifying the registry. Or as they say: "Kids, don't try this at home".

After looking through the registry searching for "extend" or "desktop", I finally found a value called "Attach.ToDesktop". Over on StackOverflow there is a question which seems to imply that this value corresponds to the "Extend the desktop to this monitor" setting in the display properties.

There were several copies of this value, but one was under a key called

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Hardware Profiles\0001\System\CurrentControlSet\Services\IALM

Deleting all instances of that key solved the problem. I rebooted, and my display now works again.

Indeed, googling a bit more, I found out this had to do with Intel. I first try to reset (some) of those values to 0 and rebooted, but it didn't work, so I decided to delete it altogether, hoping it would re-create nice default values. It did.

share|improve this answer
    
Glad to hear you fixed it! –  Ivo Flipse Oct 16 '09 at 12:05

Have a look at your power settings

DVI and DisplayPort digital graphics output ports are not supported in "Energy Savings" mode.

This is the expected behavior of the Switchable Graphics architecture. The discrete graphics adapter must be active to use a digital graphics output port.

Note that when in Energy Savings mode, only the integrated graphics adapter is active, and only displays numbered 1 and 2 are shown.

And just a question: does that notebook come with an integrated GPU or the ATI/nVidia one?

And have a look at your Bios Settings:

Running Windows XP SP 2.

Display settings in Bios configured as follows

-- Boot display: PCI - Express

-- Video card: Switchable -- ( < ---THIS was the key setting in getting it to work)

--OS Detection for switchable: Disabled.

share|improve this answer
    
Thanks Ivo. I had a look at the SwitchableGraphics page you linked to, but it says this feature is only available with Vista - not my case. I don't think that's the problem. –  Carl Seleborg Oct 16 '09 at 11:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.