Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having problems with resolving domains at work. The domain is company.local . When I connect, my etc/resolv.conf looks like this:

# Generated by NetworkManager
domain company.local
search company.local
nameserver 10.0.0.60
nameserver 10.0.0.61

I can fix the problem (hosts not getting resolved) by doing editing the file to:

# Generated by NetworkManager
domain company.local.
search company.local. office.company.local.
nameserver 10.0.0.60
nameserver 10.0.0.61

How can I set these more permanently? Something in /etc/sysconfig/network? I'm on fedora 17.

share|improve this question

migrated from stackoverflow.com Mar 4 '13 at 9:19

This question came from our site for professional and enthusiast programmers.

    
This is not a programming question. –  unwind Mar 4 '13 at 8:27

1 Answer 1

up vote 1 down vote accepted

Your /etc/resolv.conf is being populated based on the response got from the DHCP server.

Best solution for you would be to start using dnsmasq as the DNS resolver instead of the default DNS resolver.

This way you can specify additional search domains through config files which would not be over-written. Let me know and I can guide you through the steps for setting up dnsmasq as your DNS resolver.

If you already have dnsmasq configured, these are the lines you would need to add to your /etc/dnsmasq.conf based on the info you posted.

server=/office.company.local/10.0.0.60
server=/office.company.local/10.0.0.61
share|improve this answer
    
I already seem to have dnsmasq installed. The manpage is insanely big. What should I do exactly? –  Karlo Mar 4 '13 at 9:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.