Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

UPDATE 4:

After trying what JohnnyVegas suggested, I connected the dongle to the host machine, it wanted to install it's drivers, I cancelled the installation. I removed all network connections from the guest os, I added the usb dongle as a usb device for the guest os. I booted into the guest os, I selected the usb dongle from within the guest os and got the following message from virtualbox:

Failed to attach the USB device ZTE,Incorporated ZTE WCDMA Technologies MSM to the virtual machine Ubuntu 10.04 32.

USB device 'ZTE,Incorporated ZTE WCDMA Technologies MSM' with UUID {a37699df-38f1-4a82-b514-ecb4996aa98b} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057) Component: HostUSBDevice Interface: IHostUSBDevice {173b4b44-d268-4334-a11d-b6521c9a740a} Callee: IConsole {db7ab4ca-2a3f-4443-9243-c1208da92392}

Any idea why this is happening?


UPDATE 3:

It seems the problem happens when I connect a device which is of type Dial-up. If I connect a device which is of type LAN or High-Speed Internet, that device works fine.

How do I get a Dial-up usb connection as an option in virtualbox?

To prevent people from having to read the whole question. I basically want to use 2 connections on my computer. The host os should use the ethernet connection, and the guest os via virtualbox should use the usb connection which is a 3g usb dongle and comes up in xp as a dial-up connection. For some reason, I can't see this connection in virtualbox.

However, if I connect a different usb connection to the host machine which is of type LAN or High-Speed Internet, that works fine in virtualbox. I basically, need to get the dial-up connection recognised in virtualbox.


UPDATE 2:

Here is a screenshot to show that I can only see the ethernet connection in the virtualbox dropdown. The usb connection cannot be seen. You can see that both the ethernet connection and the usb connection are connected before I start virtualbox in the screenshot in the original question below. But here is the screenshot of the dropdown in virtualbox:

enter image description here


UPDATE 1:

The answer by JohnnyVegas partially works, in that if both connections are connected, the default becomes the ethernet connection. If I then go the the virtualbox OS, it too will use the ethernet connection. If either 1 of the connections is connected alone, virtualbox OS will use whichever connection is connected. However, if both connections are connected, the default is the ethernet connection, so virtualbox OS ends up using the ethernet connection.

I need the host pc to use the ethernet connection and the virtualbox OS to use the usb connection. So the answer by JohnnyVegas solves half of the problem.


ORIGINAL QUESTION:

I can't seem to get 2 internet connections to work on my computer how I need them to work.

The host computer is Windows XP, which has a ethernet connection and a USB internet connection. Both connections work fine if used one at a time.

If both connections are switched on at the same time, Windows XP wants to make use of the USB connection for some reason. How do I always get the HOST PC to make use of the ethernet connection only, but leave the USB connection enabled so it can be used by a guest OS via VirtualBox? Here is a screenshot:

Screenshot

From the screenshot, you can clearly see that I have 2 connected connections, 3Connect is the USB connection and Local Area Connection is the ethernet connection.

You can also see the Advanced Settings dialog box, which for some reason does not show the USB connection. However, if I go to Google with both connections connected, and type what is my ip, Google shows me the IP address of the USB connection. As soon as I disconnect the USB connection and refresh Google, I get the ethernet connections IP address when I ask Google what is my ip.

So basically, how do I enable both connections at the same time, but get Windows XP to make use of the ethernet connection, leaving the USB connection free for me to use with guest OS's via VirtualBox?

share|improve this question
    
See my answer here. use that to change the priority. Then choose the other connection in the virtual computer settings. superuser.com/questions/559181/… –  Gjordis Mar 4 '13 at 10:34
    
Thoose instructions seem to be for Windows Vista or Windows 7. Any chance of getting Windows XP specific instructions? As the small differences in wording between the different OS's is confusing. –  oshirowanen Mar 4 '13 at 10:39
    
same place, just don't go through network and sharing center. Go to network settings, where you see the individual adapters. From there on it's the same –  Gjordis Mar 4 '13 at 10:40
    
Found it, thanks. But in the connections list in the advanced settings dialog box, I can't see the usb connection. I can only the local area connection and the virtualbox connection. But when I go to google and type in "what is my ip", it gives me the ip address of the usb connection instead of the lan connection... –  oshirowanen Mar 4 '13 at 10:47
    
Updated the question with further details and a screenshot. –  oshirowanen Mar 4 '13 at 11:17
show 5 more comments

7 Answers

up vote 3 down vote accepted

You need to change the interface metric. This is the order which windows uses the network cards. By default windows XP sets this to 'automatic' with the checkbox (pictured). The interface metric value is in your local area connection properties, TCP/IP, then advanced. Change the TCP/IP metric on the card you wish XP to use (ethernet) to metric value 1, and the USB connection to metric value 2.

Windows will then always use the ethernet connection, if available. Don't bother too much with the bindings screen. I find the above method far better.

interface metric windows xp

As far as Virtualbox goes, it does not see the USB adapter as a network adapter, so if you remove all of the network adapters in virtualbox and configure it's USB to take over that device, it will appear in virtualbox and then install the connection software in the Virtualbox OS. USB devices and Virtualbox is always very buggy. Make sure you have the latest version of VB. Whilst it will have full access to the USB device, the Host system may not.

share|improve this answer
    
Thanks for the reply. This solves half of the issue. The other half is still a problem. Please see the update in my question. Thanks. –  oshirowanen Mar 6 '13 at 12:25
    
Just tested the solution concerning Virtualbox and I got it to work fine. Let me know how you get on. –  JohnnyVegas Mar 7 '13 at 8:35
    
Added update 3 to the question. –  oshirowanen Mar 8 '13 at 10:13
    
Please see update 4. –  oshirowanen Mar 8 '13 at 15:24
add comment

Although the host uses the Ethernet adapter, the guest can use another adapter and is not limited to using the default one of the host.

Go to Settings of the guest, Network section, use Bridged networking and specify the USB adapter in the "Attached to" field for the guest.

As a result the guest will use the USB adapter for networking, while the host will continue to use the Ethernet adapter.

[EDIT]

As you say that the USB dongle cannot be seen in the VirtualBox list of adapters, a workaround might be to use the Microsoft Loopback Adapter and bridge it to the dongle.

VirtualBox will probably be able to see the loopback adapter, while in effect it will be seeing the dongle.

share|improve this answer
    
When I go to the network settings of the guest os in virtualbox. I see a dropdown for attached to, which includes options like nat, bridged adapter, internal network etc. Under that I have a Name dropdown, which just shows the ethernet connection, it does not have the usb connection listed in that dropdown. After that I have an advanced section, and the dropdowns in that section don't have a usb connection either. –  oshirowanen Mar 6 '13 at 14:45
    
Was the USB adapter connected before you invoked virtualbox? –  harrymc Mar 6 '13 at 15:12
    
Yes, to start off with I plugged in the usb adapter, then the ethernet connection. Noticed that the eathernet connection was being defaulted too. Started virtualbox, and I can only see the ethernet connection via virtualbox. Can' see the usb connection anywhere. –  oshirowanen Mar 6 '13 at 15:36
    
I've updated my question update 2 with another screenshot, to show you what I see in the dropdown menu. –  oshirowanen Mar 6 '13 at 16:47
    
What happens if (1) you try to force the issue by disabling ethernet, so virtualbox sees the usb adapter, set it as the adapter to use, then re-enable ethernet? (2) And if this works, does it survive after a restart of virtualbox? (3) try also to plug and unplug the usb several times, (4) try to run virtualbox as administrator. –  harrymc Mar 6 '13 at 17:50
show 12 more comments

connect your dongle to the first PC and complete the driver installation on the same. go to to "My network places" on your Windows XP machine, and "Set up a home or small office network" Follow the Wizard by clicking next, then next again. The wizard will find your dongle network connection and will prompt you if "you want to use the shared connection?" decline by selecting the radial button with a no answer. Click next.

Select a connection method: Select the radial button with the corresponding text as follows; This computer connects directly to the internet. "The other computers on my network connect to the internet through this computer". Click next

Select your internet connection: From the list of available networks shown, select your 3G dongle then click next.

Name your host computer as is appropriate and click next.

Take note of your workgroup name, as all computers in this network shall be given the same workgroup name. Click next.

You can choose to allow or not the file n printer sharing feature. Click next.

Click next to apply network settings.

Select "just finish......." click next

Click finish

Go to the client computers and move into "My Network Places"

select "Set up a home or small office network" Click next

Click next again

Select a connection method: select the radial button with the text; "This computer connects to the internet through a residential gateway or through another computer on my network. Click next

Set this computer's name and description as appropriate.Click next

Ensure you had set this machines' workgroup similar to the host computer.Click next

Select the to either share or not your files and printer. click next.

click next

click finish.

repeat the second configuration for client computers on the network.

share|improve this answer
add comment
  • Click the Start Button
  • Right Click "Network" and then left Click Properties
  • From the "Network And Sharing Center" window click "Change Adapter Settings"
  • On the "Network Connections" window, press the ALT key on your keyboard to being up the menu bar
  • Click the "Advanced" menu and then "Advanced Settings"

In the "Advanced Settings" window you will see the "Adapters and Bindings" tab and under "Connections" you will see the order they are in, you can use the arrows to the side to move the connection priority up and down.

share|improve this answer
    
He's using XP, not Vista/Windows 7 –  Canadian Luke Mar 6 '13 at 16:09
    
Added update 3 to the question. –  oshirowanen Mar 8 '13 at 10:13
add comment

Use Connectify Dispatch to limit USB network to VirtualBox. It can work with all of your needs.

share|improve this answer
    
Added update 3 to the question. –  oshirowanen Mar 8 '13 at 10:14
add comment

What you actually need is either:

  • Routing (with windows included GUI, a third party program or the MS route program). This is what you need if you want to access web site A with the ethernet connection and web site B with the USB connection. This is also what you can use to change the default gateway.
  • USB device association to the VM. This is what JohnnyVegas told you to do. This is, IMHO the best way to get what you want:
    • In VB, disable all the network connections: you won't need them. When I say disabling them, I'm talking about VB configuration window.
    • Attach the USB device to the VM. If all went fine, your host won't start to use it: only the guest should now see it.
    • Install whatever you need on the guest to make the dongle work and start using it. If your guest is Windows XP, you just have to install exactly what you installed to make your dongle work on the host. But do it in the guest.
  • Policy routing. In this case, just setup VB to use NAT and add a route that defaults to the USB interface on the host if the source IP matches the one of the VM.

I think JohnnyVegas solution (#2 above) is the easiest one to setup: you don't have to setup any dial-up connection in VB. You need to setup the connection directly in the guest provided you attached your USB dongle to it. Is that clear?

I'm not familiar at all with routing under Windows and I guess it can become very painful.

share|improve this answer
    
Please see update 4. –  oshirowanen Mar 8 '13 at 15:25
    
This is happening because Windows is using the device. Remove the dongle drivers and you should be fine. –  Gael Mar 11 '13 at 18:00
add comment

This is only a direction (or an idea) and not a complete answer as I am not sure how to do this on windows or if it is possible but using iptables as firewall on linux, you could use the host firewall pre-routing table to redirect "output coming from" and "input going to" your guest vm ip to the USB adaptor instead of the LAN one.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.