Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a fresh install of the debian testing distro with gnome-shell 3.4 and it crashes daily.

By crash I mean, the sound keeps repeating itself, keyboard and mouse is unresponsive, and my only option is to pull the plug.

After reboot everything seems normal, and there's no trace of any error in /var/log or I just don't know what to look for..

I tried blacklisting the nouveau driver(/etc/modprobe.d/blacklist.conf didn't even exist! ) and removing it with modprobe -r and rmmod, but the system still crashed after a while..

The laptop is a lenovo Z580, with an intel HD 4000 and an Nvidia geForce gt365M(I suspect something with the x-server)

I just can't seem to find anything on the net that works, I searched for hours!

If you have any pointers or tips on how can I locate the problem, or find a solution, I'd really appreciate it!

UPDATE: Crashed again. I tried to ssh into the laptop, but I couldn't, it just sat there like a brick.

UPDATE2: Switched to xfce, hoping the crashes would stop, but it still crashed. This means the issue isn't with gnome!

UPDATE3: I seem to get crashes a lot more often if my usb mouse is plugged in. Maybe it has something to do with usb3?

UPDATE4: SOmetimes the distro just doesn't boot, and spits out logs(?) or error reports, I managed to photographed them(they're here), and my suspicion of USB3 is stronger with every "screenshot"... What do you think? this may worth another question...

UPDATE4: - PART 2: Also, disabling the dedicated video card didn't help...

Thank you for your help!

share|improve this question
    
I remember facing a similar, though not identical, problem on Fedora before. Try adding noacpi to your boot command line. To do this press e in your boot manager, add noacpi near the end of your boot command line (the one that starts with linux vmlinuz...) and press CTRL+X to boot with this command line. Note that disabling acpi will not give you access to power information within Debian. You can also check the logs (/var/log/messages and ~/.xsession-errors) for hints on what may be causing the problem. –  Joseph R. Mar 4 '13 at 16:04
    
what exactly does noacpi do? –  Y.T. Mar 4 '13 at 16:47
    
and i looked into /var/log/messages.1, and the last message said: Mar 3 13:28:12 yeticave rsyslogd: [origin software="rsyslogd" swVersion="5.8.11" x-pid="2306" x-info="rsyslog.com"] rsyslogd was HUPed –  Y.T. Mar 4 '13 at 16:59
    
Well, I'm not quite sure on the technical details of noacpi. acpi is "Advanced Control and Power Interface". The only effect that I could observe after disabling acpi was that battery info was no longer available. I guess fan control would also go out the window in this case. It's not an ideal solution; it may not even be a solution in your case. I'm saying that this is a common occurrence. So, if adding noacpi solves your problem, you should Google "can't boot without noacpi" or something similar. –  Joseph R. Mar 4 '13 at 17:05
    
Thank you for the insight! I'll look into it! –  Y.T. Mar 4 '13 at 17:08

1 Answer 1

up vote 1 down vote accepted

The laptop is a lenovo Z580, with an intel HD 4000 and an Nvidia geForce gt365M(I suspect something with the x-server)

1) Since you have two graphics GPUs, try to turn off the one you are using now, and force it to use the other one (if you are using Nvidia, turn it off, and just use the Intel for now). You can do this in bios.

This will at least sort out whether it is the nvidia chipset/driver or not.

2) You can also try to use the binary nvidia driver instead of nouveau (this will narrow whether the problem is driver specific)

3) You can try running your WM without opengl hardware acceleration (so run in software mode only) -- google for settings in gnome to accomplish this. This would tell you whether it is hardware acceleration related (so acceleration/compositing/effects) or not.

4) Could it be your CPU or GPU is getting too hot? What is its temperature when it loses its mind? Try watching CPU and GPU temperature while using your machine.

If you still have crashes after eliminating the temperature, chipset and driver in use, it is something other than graphics possibly, or something dependent or interacting with graphics.

share|improve this answer
    
Does it matter if I couldn't ssh into the laptop while it crashed? I don't think the problem is x-server related because of that. Also did a couple of stress-tests and it didn't crash. I would really like to have a workaround of disabling the Nvidia video card in BIOS, since I have windows with my debian install. –  Y.T. Mar 7 '13 at 6:53
1  
If you couldn't ssh, that means it's hard locked, it wasn't just the x-server that crashed, it was the kernel. One of my suggestions was to try the nvidia binary driver rather than nouveau. If you temporarily disable the nvidia chipset and just use intel and the problem goes away you can eliminate the X-server as the problem. If you switch to nvidia binary driver from nouveau and the problem goes away, you know it is the nouveau driver. –  mike Mar 7 '13 at 18:39
    
I'll try disabling the nvidia card from the BIOS and see if the problem remains. Is there a way to do it from linux boot? –  Y.T. Mar 10 '13 at 19:12
    
nope, I still got a crash, while the dediacated cars was disabled.. :\ –  Y.T. Mar 12 '13 at 9:08
    
I think it is something related to usb3, but I'M not sure, what do you think(I updated the question) –  Y.T. Mar 13 '13 at 12:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.