Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Acer Aspire 5755g running Windows 7 Ultimate 64Bit which keeps dropping the wireless connection to the internet. Sometimes it can be within minutes and other times it will happen after an hour or so.

I have tried to use a different router and using a different ISP and still with the same problem. I have tried the trouble shooter for the network and also for the whole device(machine).

Something strange is that when I have the problem and I go to restart or shut down my machine it takes a very long time to shut down and even in some cases I have to hold down the power key to force shutdown, but when I restart the machine it seems to work fine again for a little while before the same thing happens.

I have checked the drivers and everything seems fine. I cannot think of what else to try so any help would be appreciated.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

I had the same problem couple months ago.

My ThinkPad running Windows 7 (x64) was losing connection to the internet very often even if laptop was connected to the D-link router (WiFi icon in task bar was showing strong signal). XP computers and Android tablets were OK.

I tried many suggestions found on internet from other users, nothing worked. Then I discovered that this happened only if one of WiFi adapters in my network is on. It was TV WiFi receiver.

In TV Connection Settings, in Obtain IP Address I changed from Automatic to Manual, assigned permanent IP address within my network domain and that’s it. I haven’t had one internet connection drop since then.

I don’t know if you can apply the same approach to your WiFi devices in your network, but it works for me 100%.

share|improve this answer

I've had my Aspire 5575G for a couple of years now and have the same problem (after re-installing Windows 7 and Windows 8/8.1 more than once as well). When the internet connection is lost it is not only my home router that I can't see - I can't see any available connections. After this has happened I can't usually get it back again through the troubleshooter resetting the device so have to restart the computer.

It usually happens when the machine is running hot (I've got the dedicated 2GB graphics model and use it for gaming which really increases the running temperature but it can get hot even without doing a lot of work as well) and usually when I move the notebook around.

I should have sent it in under warranty but I was too slack and now I'm stuck with it. I've thought about just buying a reasonable USB Wifi adapter but I would recommend you get in touch with Acer about it if you're still in the warranty period.

share|improve this answer

You could also try updating (or downgrading) the firmware version for the router. For whatever reason the most recent update for my Netgear router was dropping connections every five minutes. I installed firmware for the router a couple versions back and the connection seems to be holding quite well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.