Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

With the new Office 2013, a new Microsoft Office Upload Center is started. But I don't use that and want to remove it completely (not just hiding).

How can I remove that program completely?

enter image description here

share|improve this question
1  
Have you looked into msconfig? (WIN) + (R) -> msconfig -> Systemstart –  Peter I Mar 5 '13 at 8:21
    
You can't remove it completely you can just simply configure it not to start when your computer is rebooted. –  Ramhound Mar 5 '13 at 11:07
    
It's not in the startup folder. But I think it always starts when I launch Microsoft Word, Excel or Outlook. I don't want to have background apps that I don't use... –  FiveO Mar 6 '13 at 8:31
    
The application is supposed to "Manage Office document uploads to web server"?? And you can't close it down? What is wrong with you Microsoft? –  user80237 Jul 10 '13 at 10:41
add comment

9 Answers

up vote 37 down vote accepted

"You can't disable it and if you remove it from start up it still loads up anyway. All you can do is open task manager and end the process for MSOSYNC.EXE, pretty lame I know, but there's no way of disabling it and this info is coming from the office365 forum!"

Not true.

You can disable the Microsoft Office Upload Center easily in the registry- but this is the only way.

Microsoft went out of their way to stop people from doing this in the GUI, and even MSCONFIG won't work.

Here's the registry fix (only tested on Windows 7 + Office 2010... see other answers for more recent versions of Windows/Office):

Locate:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

and delete the OfficeSyncProcess entry that points to the current location of MSOSYNC.EXE.

Microsoft's arrogance on this whole issue is astonishing:

enter image description here

Many people are turning to forums in frustration to turn off this feature.

These people want to disable it, so do these, and these, and even these.

It shouldn't be enabled automatically when you simply run SharePoint/SkyDrive once- and if it is, then it should be possible to turn it off without rolling up your sleeves and hacking the registry.

Poor show, Microsoft. Poor show.

share|improve this answer
7  
Alas, on Win8 there is no such key for me in the registry. –  Jeroen May 13 '13 at 6:09
6  
+1 for "Poor show, Microsoft. Poor show." –  Daniel Bahmani Sep 14 '13 at 15:18
    
I'm using Windows 7 Pro joined to a domain. No key at that location or at the same place under HKLM. –  Jeremy Sep 27 '13 at 16:59
4  
Office 2013 users, please see this answer. It worked for me without having to modify any registry entries manually. Good riddance Microsoft Office Upload crapware. –  crayzeewulf Oct 7 '13 at 23:23
2  
You can also use "AutoRuns sysinternal tool" to disable it at the login. –  boos Mar 20 at 13:38
show 4 more comments

To disable/configure this open up Task Scheduler and click on the Task Scheduler Library node. You should see a task here labelled 'Microsoft Office 15 Sync Maintenance for USERNAME'. Change the properties of this to amend the trigger that starts the job. For instance, you can delete the trigger that starts on user log on.

share|improve this answer
    
Thanks! This worked for me with Office 2013 on Windows 7. Also, user MJS1A suggested the same here. –  crayzeewulf Oct 7 '13 at 23:22
    
Thanks @user209050Or edit the task to run one time in 2099..... –  wruckie Feb 4 at 1:53
    
Worked for me, thank you! –  qlf00n May 20 at 5:28
add comment

Out of desperation I renamed the executable msosync.exe so that office cannot find it. Dirty, yes, but I have had no problems with this approach and now my computer works much better again :)

share|improve this answer
    
Where is msosync.exe located so I can rename it? –  culix Aug 25 '13 at 7:08
    
@culix C:\Program Files\Microsoft Office\Office14 –  Daniel Bahmani Sep 14 '13 at 15:17
    
I did the same, but then after some time (I guess after an update) the exeutable is back there, running. I'm now trying the Task Scheduler approach suggested by user209050 –  superjos Feb 28 at 9:46
add comment

Just rename this file

C:\Program Files\Microsoft Office\Office15\msosync.exe
share|improve this answer
    
A bit a a brutal method, but when it works... (hopefully this doesn't generate any error messages) –  FiveO Oct 2 '13 at 6:01
    
Good to know there's a solution for Office 2013! –  Austin ''Danger'' Powers Oct 6 '13 at 0:59
add comment

It appears that with Office 2013, MSOSYNC is under a new process called "CSISYNCCLIENT.EXE" I found this in process explorer. Perhaps if you searched for that in the registry, it could be disabled

share|improve this answer
    
Sounds like you're on to something there, Kevin! Alas, my answer only covered Windows 7 with Office 2010, as that's what I run at home and was able to test it on. –  Austin ''Danger'' Powers Oct 6 '13 at 0:58
add comment

You might want to have a look at this MS answer.
In that case the user removed Office 2013, but still had SkyDrive Desktop app installed, and there was a SkyDrive setting referring to the upload center.

In my case, I only had Sharepoint Designer 2013 installed (Office suite was stuck at 2010, and I already disabled its upload center): that answer worked for me.

share|improve this answer
add comment

You can't disable it and if you remove it from start up it still loads up anyway. All you can do is open task manager and end the process for MSOSYNC.EXE, pretty lame I know, but there's no way of disabling it and this info is coming from the office365 forum!

share|improve this answer
add comment

For Windows 7/8 Users this process can be disable from auto-run only by accessing Task Scheduler in Control Panel -> Administrative Tools . You must Look for Microsoft -> Office Folder and disable all tasks located in Office folder.

share|improve this answer
add comment

This is a terrible MS pushed annoyance, and to make it worse, MS insists that you use it by constantly avoiding previous removal procedures. So here is my attempt to collect and update some (currently) working solutions. The post answers here will probably need to be updated again, in a few months...

These instructions are for disabling Microsoft Office Upload Center on the MS Office 2013 Home & Student Edition on Windows 8.1.

  1. Optionally:

    • Uninstall SharePoint
    • Uninstall SkyDrive
  2. Kill the processes:

    a) Stop the system service "Microsoft Office Service". (Perhaps permanently disable?)

    b) Use Process Explorer to kill all of the following processes if present:

    integratedoffice.exe
    MSOSYNC.EXE
    CSISYNCCLIENT.EXE
    OSPPSVC.EXE
    MSOUC.EXE 
    

    c) Rename the following *.EXE files by adding ".disabled" to thier filenames in [1]:

    C:\Program Files\Microsoft Office 15\root\office15\MSOUC.EXE
    C:\Program Files\Microsoft Office 15\root\office15\MSOSYNC.EXE
    

    and possibly also:

    C:\Program Files\Microsoft Office 15\root\office15\MSOHTMED.EXE
    

    [1] This folder have also been found to be located in:

    C:\Program Files\Microsoft Office\Office15\
    
  3. Replace the above files with fake *.EXE files:

    a) Create and edit a new text file called MSOSYNC.txt with command:

    quit
    

    b) Copy and rename the file MSOSYNC.txt to:

    MSOSYNC.EXE
    MSOUC.EXE
    

    c) Set correct file permissions, if necessary.

  4. Remove the entry from the Task Scheduler:

    a) Open Control Panel and go to:

    Control Panel >> System and Security >> Administrative Tools
    

    b) Select and open "Task Scheduler".

    c) Click on the "Task Scheduler Library" icon. [on the left side/pane]

    d) Find and click on:
    "Microsoft Office 15 Sync Maintenance for - "

    e) Click on the "Actions" [tab] and check that it reads something like:

    C:\Program Files\Microsoft Office 15\Root\Office15\MsoSync.exe
    

    f) In the right pane, under "Selected Item", click "Disable"

  5. Other suspicious tasks to check:

    1) Expand the "Task Scheduler Library" tab [on the left pane]
    2) >> Microsoft >> Office >> Office Automatic Updates
    3) >> Microsoft >> Windows >> SettingSync >> BackgroundUploadTask
    4) >> Microsoft >> Windows >> SkyDrive >> Idle Sync Maintenance Task 
    
  6. Disallow Office to connect to the internet.

    a) Open any office application like Word, and go to:

    File >> Options >> Trust Center [on bottom left]
    

    b) Under "Microdsoft Word Trust Center" header [bottom], select:

    "Trust Center Settings..." button [bottom right] 
    

    c) In the new "Trust Center" window go to:

    Privacy Options [on bottom left]
    

    d) Under "Privacy Options" header, unselect Allow Office to connect to the Internet.


Here are some additional possible solutions, but which I have not tried:

  1. Change the Group Policy for Everyone, by adding MSOSYNC.EXE to 'List of disallowed applications'.
  2. Disable the system service called: "Microsoft Office Service"
  3. Edit the registry...
  4. Removing everything related to the "Microsoft Office Workspaces".
share|improve this answer
    
This approach seems to be quite overkill and might even produce errors if there are any dependencies between those files and Office... I would recommend to use the Task Scheduler approach - it's straight forward and all the dependencies are left intact. PLus: you are actually killing SkyDrive's synchronisation which might NOT be what some people had in mind when searching for "how to disable msosync". –  Betaminos Jul 7 at 9:05
    
@Betaminos: This is not an overkill at all, as every time any Office related MS updates have been run, I have to pretty much go through the same sequence again. And if SkyDrive require MSOSync or vice versa, that would be a bug issue to post at MS forums. I'm sure they will be very helpful there! Also notice I wrote optionally on the SkyDrive uninstall item. (Because if you do use SkyDrive, it will want to "help" you also synchronize your office stuff, and then BAM! we're back to step again.) –  user1147688 Jul 7 at 11:20
add comment

protected by Community Oct 23 '13 at 21:27

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.