Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The context is the following one :

  • Users can open eml files from explorer with desktop client (like lotus notes)
  • When the eml file is opened from the website this response header : Content-Type: message/rfc822 along with Content-Disposition: inline; filename="myfile.eml are sent to Internet explorer
  • This mime type is common between mhtml and eml files
  • I used "inline" as I want to minimize user interaction (avoid open/save dialog box)
  • Internet Explorer 9 as the default explorer always recreates the following registry entry HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\MIMEAssociations**message/rfc822**\UserChoice "Progid"="IE.message/rfc822"
  • If this entry is removed eml files are opened with my desktop mail client
  • But any changes tho this entry is detected by IE during launch and it asks to be the default browser to restore the registry entry above

Do you have an idea for a workaround ?

What I can do

  • Change the way the way the eml file is treated by the website
  • change IE Settings (it's an intranet, I can deploy registry patches !)

What I can't do

  • use a different browser (chrome, firefox)
  • make IE a non default browser

Regards

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I had a call with Microsoft
The solution is in the registry : you have to remove some "Capabilities" to IE

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Capabilities\MIMEAssociations\message/rfc822]

[-HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\Capabilities\MIMEAssociations\message/rfc822]

[-HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Capabilities\MIMEAssociations\message/rfc822]

With that I can

[HKEY_CLASSES_ROOT\MIME\Database\Content Type\message/rfc822] "CLSID"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\MIME\Database\Content Type\message/rfc822] "CLSID"=-

and more important :

HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\MIMEAssociations\message/rfc822]

and Internet explorer won't check that he is the non default program for message/rfc822

Do not forget to associate .eml files to your desktop client (like notes)

[HKEY_CLASSES_ROOT.eml] @="Notes.emlfile" "Content Type"="message/rfc822"

[HKEY_CLASSES_ROOT.eml\shell]

[HKEY_CLASSES_ROOT.eml\shell\open]

[HKEY_CLASSES_ROOT.eml\shell\open\command] @="\"C:\Program Files (x86)\IBM\Lotus\Notes\notes.exe\" -defini \"%1\""

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.