Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using PDFXchange Viewer to open PDF files, because it's much faster compared to Adobe Reader and I like the rendering better. I had to install Adobe Reader for testing purposes, and now Firefox opens every PDF document with the ultra-slow Adobe Reader. In the settings of Firefox, it still says that PDFXchange is used to open PDFs, but this is not the case.

How can I get rid of the Adobe Reader opening PDFs directly in Firefox without uninstalling something?

share|improve this question
Have you tried disabling the plugin as per the instructions here: ? – rink.attendant.6 Mar 5 '13 at 12:25
Options > Applications > PDF -> Choose plugin. – Wk_of_Angmar Mar 11 '13 at 18:31

Go into the Add-ons Manager and select the Plugins tab. From here you can disable any installed plugins, like Acrobat, Flash, Silverlight, Java, etc.

enter image description here

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.