Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to install/configure CommCare HQ on Ubuntu 12.04 LTS. I've installed all dependencies, set them up and running, when I entered the command

 ./manage.py syncdb --noinput

show the followings error:

INFO Raven is not configured (disabled). Please see documentation for more information.
Syncing...
Creating tables ...
sync `auditcare` in CouchDB
Traceback (most recent call last):
  File "./manage.py", line 30, in <module>
    execute_manager(settings)
.
.
.
.
raise RequestError("socket.error: %s" % str(e))
restkit.errors.RequestError: socket.error: [Errno 1] _ssl.c:504: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

please guide me way to come out of this error

share|improve this question

migrated from stackoverflow.com Mar 5 '13 at 12:35

This question came from our site for professional and enthusiast programmers.

It looks like your couchdb settings may not have been setup correctly. You should make sure the following settings in your localsettings point to the right database:

####### Couch Config ######
COUCH_HTTPS = False # recommended production value is True if enabling https
COUCH_SERVER_ROOT = '127.0.0.1:5984'
COUCH_USERNAME = 'admin'
COUCH_PASSWORD = '********'
COUCH_DATABASE_NAME = 'commcarehq'

https://github.com/dimagi/commcare-hq has pretty solid installation instructions that should work on Ubuntu 12.04

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.